aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-04-17 21:58:30 +0800
committerjbeich <jbeich@FreeBSD.org>2015-04-17 21:58:30 +0800
commite0dddd29f4045be96ca8e346847a387cb6ba5629 (patch)
treec872a6e6fb0a7d042b1b30b9bf54f8a5ac02f9db /games
parent5e8cb142f456a023fd3b896d15318d87915a41ff (diff)
downloadfreebsd-ports-gnome-e0dddd29f4045be96ca8e346847a387cb6ba5629.tar.gz
freebsd-ports-gnome-e0dddd29f4045be96ca8e346847a387cb6ba5629.tar.zst
freebsd-ports-gnome-e0dddd29f4045be96ca8e346847a387cb6ba5629.zip
- Add CPE information
- Require openmp-capable compiler for OPENMP PR: 199497 Approved by: Torsten Zühlsdorff (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/wesnoth/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index f14df4d17246..8e17b40f6692 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -23,7 +23,9 @@ LDFLAGS+= -L${LOCALBASE}/lib -lboost_system
USE_SDL= image mixer net ttf
USE_GNOME= pango
-USES= cmake pkgconfig tar:bzip2
+USES= cmake cpe pkgconfig tar:bzip2
+CPE_VENDOR= ${PORTNAME}
+CPE_PRODUCT= battle_for_wesnoth
CMAKE_ARGS= -DMANDIR="man" -DENABLE_STRICT_COMPILATION=off
PORTDOCS= *
@@ -51,6 +53,7 @@ NOTIFY_DESC= Desktop notifications
NOTIFY_LIB_DEPENDS=libdbus-1.so:${PORTSDIR}/devel/dbus
NOTIFY_CMAKE_OFF=-DENABLE_NOTIFICATIONS=off
OPENMP_DESC= OpenMP support
+OPENMP_USES= compiler:openmp
OPENMP_CMAKE_ON=-DENABLE_OMP=on
RAWSOCKETS_DESC= Use raw receiving sockets in multiplayer
RAWSOCKETS_CFLAGS=-DNETWORK_USE_RAW_SOCKETS