aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-12-23 14:51:39 +0800
committernemysis <nemysis@FreeBSD.org>2013-12-23 14:51:39 +0800
commite5c272e51a9db07f3ff2c534625a98e638d5592e (patch)
treea5c855878356a00e21acf5a53c54e3d5966f9155 /games
parent0665c2f1e7d017e35681fc209f137e2b2627907e (diff)
downloadfreebsd-ports-gnome-e5c272e51a9db07f3ff2c534625a98e638d5592e.tar.gz
freebsd-ports-gnome-e5c272e51a9db07f3ff2c534625a98e638d5592e.tar.zst
freebsd-ports-gnome-e5c272e51a9db07f3ff2c534625a98e638d5592e.zip
- Change Makefile header
- Bump PORTREVISION for dependency change - Add dependency for textproc/p5-XML-Parser - Add USES iconv - Add DOCS Option - Support STAGEDIR Approved by: pawel / wg (mentors, implicit)
Diffstat (limited to 'games')
-rw-r--r--games/glightoff/Makefile29
1 files changed, 12 insertions, 17 deletions
diff --git a/games/glightoff/Makefile b/games/glightoff/Makefile
index 36a425f7b5bf..0d965723d918 100644
--- a/games/glightoff/Makefile
+++ b/games/glightoff/Makefile
@@ -1,19 +1,21 @@
-# Created by: nemysis@gmx.ch
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= glightoff
PORTVERSION= 1.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
MAINTAINER= nemysis@FreeBSD.org
COMMENT= Simple (but not so easy to solve!) puzzle game
+BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
+
LICENSE= GPLv2
+USES= gmake iconv pkgconfig
GNU_CONFIGURE= yes
-USES= gmake pkgconfig
USE_GNOME= glib20 gtk20
USE_XORG= x11
@@ -22,27 +24,20 @@ LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= AUTHORS ChangeLog NEWS README TODO
-OPTIONS_DEFINE= NLS
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+NLS_USES= gettext
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-PLIST_SUB+= NLS="@comment "
-.endif
+.include <bsd.port.options.mk>
post-configure:
-.if !${PORT_OPTIONS:MNLS}
+.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} 's|src po|src|' ${WRKSRC}/Makefile
.endif
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>