aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2013-11-23 21:16:59 +0800
committerak <ak@FreeBSD.org>2013-11-23 21:16:59 +0800
commited01a99cfd709ff4ed8c10b3f6bd4858becea3a4 (patch)
tree7ecc6933470ffccd9866c87af8969106c52f6a46 /games
parent06e878c297ea83ad72b700c048ac85916751911d (diff)
downloadfreebsd-ports-gnome-ed01a99cfd709ff4ed8c10b3f6bd4858becea3a4.tar.gz
freebsd-ports-gnome-ed01a99cfd709ff4ed8c10b3f6bd4858becea3a4.tar.zst
freebsd-ports-gnome-ed01a99cfd709ff4ed8c10b3f6bd4858becea3a4.zip
- Support STAGEDIR
- Convert to new LIB_DEPENDS syntax - Update to 0.8.0.1 [1] PR: ports/184077 (based on) [1] Submitted by: Timothy Beyer <beyert@cs.ucr.edu> (maintainer) [1]
Diffstat (limited to 'games')
-rw-r--r--games/gemrb/Makefile36
-rw-r--r--games/gemrb/distinfo4
-rw-r--r--games/gemrb/pkg-plist1
3 files changed, 7 insertions, 34 deletions
diff --git a/games/gemrb/Makefile b/games/gemrb/Makefile
index 925dd379f57b..d673922eae10 100644
--- a/games/gemrb/Makefile
+++ b/games/gemrb/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= gemrb
-PORTVERSION= 0.8.0
+PORTVERSION= 0.8.0.1
CATEGORIES= games emulators
-MASTER_SITES= SF/${PORTNAME}/GemRB%20Sources/GemRB%20${PORTVERSION}%20Sources
+MASTER_SITES= SF/${PORTNAME}/GemRB%20Sources/GemRB%20${PORTVERSION:.1=}%20Sources
MAINTAINER= beyert@cs.ucr.edu
COMMENT= GemRB (Game engine made with preRendered Background)
@@ -12,8 +12,8 @@ COMMENT= GemRB (Game engine made with preRendered Background)
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- vorbis:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
USES= cmake
USE_SDL= sdl mixer ttf
@@ -24,32 +24,4 @@ CFLAGS+= -L${LOCALBASE}/lib -I${LOCALBASE}/include
CMAKE_C_FLAGS= ${CFLAGS}
CMAKE_ARGS= -DDOC_DIR="${DOCSDIR}" -DMAN_DIR="${MAN6PREFIX}/man/man6/" -DDISABLE_WERROR=1 -DINSOURCEBUILD=1
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-MAN6= gemrb.6
-
-post-patch:
- @${REINPLACE_CMD} \
- -e '/^ADD_SUBDIRECTORY( VLCPlayer )/d' \
- ${WRKSRC}/gemrb/plugins/CMakeLists.txt
-
-.if empty(PORT_OPTIONS:MDOCS)
- @${REINPLACE_CMD} \
- -e '/^INSTALL( FILES README INSTALL COPYING NEWS AUTHORS DESTINATION \$${DOC_DIR} )/d' \
- ${WRKSRC}/CMakeLists.txt
- @${REINPLACE_CMD} \
- -e '/^ADD_SUBDIRECTORY( docs )/d' \
- ${WRKSRC}/gemrb/CMakeLists.txt
- @${REINPLACE_CMD} \
- -e '/^ADD_SUBDIRECTORY( en )/d' \
- ${WRKSRC}/gemrb/docs/CMakeLists.txt
-.endif
-
-post-install:
- @if [ ! -f ${PREFIX}/etc/gemrb.cfg ]; then \
- ${CP} ${WRKSRC}/gemrb/GemRB.cfg.sample ${PREFIX}/etc/gemrb.cfg; \
- fi
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/games/gemrb/distinfo b/games/gemrb/distinfo
index 461c6cc4f222..b56e647bbd0f 100644
--- a/games/gemrb/distinfo
+++ b/games/gemrb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gemrb-0.8.0.tar.gz) = 085af5d20e5ac4d587b3f26bb3878a0a5478e3ef8b317c4907d298c3aae1de29
-SIZE (gemrb-0.8.0.tar.gz) = 12231959
+SHA256 (gemrb-0.8.0.1.tar.gz) = 4d4fb00b09789c6de7e0959e7d7a1ccf6fc2aa6d0c86c4a6b35c45a2e9f5316d
+SIZE (gemrb-0.8.0.1.tar.gz) = 12303524
diff --git a/games/gemrb/pkg-plist b/games/gemrb/pkg-plist
index 1be7d3557d26..7473ddecf82c 100644
--- a/games/gemrb/pkg-plist
+++ b/games/gemrb/pkg-plist
@@ -48,6 +48,7 @@ lib/gemrb/plugins/WAVReader.so
lib/gemrb/plugins/WEDImporter.so
lib/gemrb/plugins/WMPImporter.so
lib/gemrb/plugins/ZLibManager.so
+man/man6/gemrb.6.gz
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/COPYING