aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2012-10-20 16:39:39 +0800
committermadpilot <madpilot@FreeBSD.org>2012-10-20 16:39:39 +0800
commitfc318c4a89ab39845a2f529bd5933a85a5e50d83 (patch)
tree83f5972532f0d970740e724ed6770c5aa522d10f /games
parent692ccf04c01d67b690cbd54d4169514e5dc07b24 (diff)
downloadfreebsd-ports-gnome-fc318c4a89ab39845a2f529bd5933a85a5e50d83.tar.gz
freebsd-ports-gnome-fc318c4a89ab39845a2f529bd5933a85a5e50d83.tar.zst
freebsd-ports-gnome-fc318c4a89ab39845a2f529bd5933a85a5e50d83.zip
- Update to 2.3.1
- Add clang support - Update MASTER_SITES - Convert to optionsng - Trim Makefile headers PR: ports/172686 Submitted by: Gautam Mani <execve@gmail.com> (maintainer) Feature safe: YES
Diffstat (limited to 'games')
-rw-r--r--games/stockfish/Makefile51
-rw-r--r--games/stockfish/distinfo4
2 files changed, 30 insertions, 25 deletions
diff --git a/games/stockfish/Makefile b/games/stockfish/Makefile
index 5cd342a0e701..a09d7f1e6acd 100644
--- a/games/stockfish/Makefile
+++ b/games/stockfish/Makefile
@@ -1,19 +1,15 @@
-# New ports collection makefile for: stockfish
-# Date created: Apr 21 2011
-# Whom: Gautam Mani <execve@gmail.com>
-#
+# Created by: Gautam Mani <execve@gmail.com>
# $FreeBSD$
-#
PORTNAME= stockfish
-PORTVERSION= 2.2.2
+PORTVERSION= 2.3.1
CATEGORIES= games
-MASTER_SITES= http://dl.dropbox.com/u/2116588/sf-archive/:src \
+MASTER_SITES= http://cl.ly/2t3y2k2Y3Y1H/download/:src \
http://www.execve.net/sf/:src \
- http://f.cl.ly/items/1y0Q3P2n0I2S0g0Y100E/:book \
+ http://api.cld.me/2R1L1Y0V0b1M3M1B1D26/download/:book \
http://www.execve.net/sf/:book
-DISTNAME= stockfish-${PORTVERSION:S/.//g}-ja
-DISTFILES= stockfish-${PORTVERSION:S/.//g}-ja.zip:src \
+DISTNAME= stockfish-${PORTVERSION:S/.//g}-linux
+DISTFILES= stockfish-${PORTVERSION:S/.//g}-linux.zip:src \
sf-211-book.zip:book
MAINTAINER= execve@gmail.com
@@ -28,39 +24,48 @@ MYARCH= ${ARCH}
BOOKDIR= sf-211-book
PORTDOCS= Readme.txt polyglot.ini
PORTDATA= Book.bin
+FETCH_ARGS= -Fpr
PLIST_FILES= bin/stockfish
PLIST_DIRSTRY= share/data/${PORTNAME} \
share/docs/${PORTNAME}
-ALL_TARGET= build ARCH=${MYARCH}
+TGTBLD= build
+MYCC= gcc
-OPTIONS= POPCNT_PROFILE_BUILD "Make a Profile build (POPCNT enabled)" Off \
- PROFILE_BUILD "Make a Profile build" Off
+.if ${CC} == "clang" || ${CXX} == "clang++"
+MYCC= clang
+.endif
-TGTBLD= build
+OPTIONS_DEFINE= DOCS POPCNT_ENABLED PROFILE_BUILD
+POPCNT_ENABLED_DESC= Use the POPCNT instruction
+PROFILE_BUILD_DESC= Make a Profile build
.include <bsd.port.options.mk>
-.if defined(WITH_PROFILE_BUILD)
+.if ${PORT_OPTIONS:MPROFILE_BUILD}
TGTBLD= profile-build
.endif
-.if defined(WITH_POPCNT_PROFILE_BUILD)
+.if ${PORT_OPTIONS:MPOPCNT_ENABLED}
.if ${ARCH} != "amd64"
-BROKEN= WITH_POPCNT_PROFILE_BUILD compiles only on amd64
+BROKEN= POPCNT_ENABLED compiles only on amd64
.endif
-TGTBLD= popcnt-profile-build
.endif
.include <bsd.port.pre.mk>
# workaround the ARCH usage in the stockfish Makefile
-.if ${MYARCH} == "i386"
-ALL_TARGET= ${TGTBLD} ARCH=x86-32
-.elif ${MYARCH} == "amd64"
-ALL_TARGET= ${TGTBLD} ARCH=x86-64
+.if ${ARCH} == "i386"
+MYARCH= x86-32
+.elif ${ARCH} == "amd64"
+.if ${PORT_OPTIONS:MPOPCNT_ENABLED}
+MYARCH= x86-64-modern
+.else
+MYARCH= x86-64
+.endif
.endif
+ALL_TARGET= ${TGTBLD} ARCH=${MYARCH} COMP=${MYCC}
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= Does not compile on ia64, powerpc, or sparc64
@@ -70,7 +75,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/stockfish ${PREFIX}/bin/stockfish
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/Readme.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/polyglot.ini ${DOCSDIR}
diff --git a/games/stockfish/distinfo b/games/stockfish/distinfo
index 5e17538e2a5f..fca568a429b8 100644
--- a/games/stockfish/distinfo
+++ b/games/stockfish/distinfo
@@ -1,4 +1,4 @@
-SHA256 (stockfish-222-ja.zip) = 068ccf7d1088e2df880fcfd326f0ac3920b05953d34ec39e6265391328d6fb9b
-SIZE (stockfish-222-ja.zip) = 2272728
+SHA256 (stockfish-231-linux.zip) = 119acf339d18b8b23c6142a72c9d8e09edf385c20a811a458bc0b63472c6a682
+SIZE (stockfish-231-linux.zip) = 852252
SHA256 (sf-211-book.zip) = fc4b2964128278dcf076b1601a5fb7a6cc88d87d9f617d32fa82aeb05cfdff74
SIZE (sf-211-book.zip) = 8831695