aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-11 19:59:55 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-11 19:59:55 +0800
commitfc6536e4588fca2be0f835e0f71ae3f8764e39f1 (patch)
tree967a60b52a2c6a55eb62c604ab020d429226e211 /games
parent6775ec204c6408f58f8a4dc680c6a82d0dca1921 (diff)
downloadfreebsd-ports-gnome-fc6536e4588fca2be0f835e0f71ae3f8764e39f1.tar.gz
freebsd-ports-gnome-fc6536e4588fca2be0f835e0f71ae3f8764e39f1.tar.zst
freebsd-ports-gnome-fc6536e4588fca2be0f835e0f71ae3f8764e39f1.zip
Track used or drop unused devel/icu dependency
This tries to fix discrepancy between $ pkg rquery '%o %B' | awk '/libicu/ { print $1 }' | sort -u $ git grep -lF :devel/icu | sed 's,/Makefile$,,' PR: 214384 Reported by: tijl, stage-qa, readelf(1)
Diffstat (limited to 'games')
-rw-r--r--games/0ad/Makefile2
-rw-r--r--games/openttd/Makefile3
2 files changed, 4 insertions, 1 deletions
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index f27a0719ae42..6b2ec2eda08c 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -2,6 +2,7 @@
PORTNAME= 0ad
PORTVERSION= 0.0.21
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://releases.wildfiregames.com/ \
SF/zero-ad/releases
@@ -14,6 +15,7 @@ COMMENT= Real-time strategy (RTS) game of ancient warfare
BUILD_DEPENDS= zip:archivers/zip \
cmake:devel/cmake
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
+ libicui18n.so:devel/icu \
libpng.so:graphics/png \
libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis \
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 80676327e5b4..41accfc62d18 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openttd
DISTVERSION= 1.6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://ca.binaries.openttd.org/binaries/releases/${DISTVERSION}/ \
http://cz.binaries.openttd.org/binaries/releases/${DISTVERSION}/ \
@@ -20,6 +20,7 @@ COMMENT= Open source clone of Microprose Transport Tycoon Deluxe
LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png \
+ libicui18n.so:devel/icu \
liblzo2.so:archivers/lzo2
USES= cpe gmake pkgconfig tar:xz