aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2019-04-28 23:09:43 +0800
committermadpilot <madpilot@FreeBSD.org>2019-04-28 23:09:43 +0800
commit12d579a72f3aafed2a46972d00a133a19d223e41 (patch)
tree780fa411741492409e18b0240e075db23fea988f /games
parent861855ee7383834245c687429440d088a13b658c (diff)
downloadfreebsd-ports-gnome-12d579a72f3aafed2a46972d00a133a19d223e41.tar.gz
freebsd-ports-gnome-12d579a72f3aafed2a46972d00a133a19d223e41.tar.zst
freebsd-ports-gnome-12d579a72f3aafed2a46972d00a133a19d223e41.zip
- Modify patch to not implicitly depend on csh during build.
- Add some missing USES PR: 237584 Submitted by: Lorenzo Salvadore <phascolarctos@protonmail.ch>
Diffstat (limited to 'games')
-rw-r--r--games/0ad/Makefile4
-rw-r--r--games/0ad/files/patch-libraries_source_fcollada_src_Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index 597a9ab6a6c8..7e7bf543eeba 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -27,8 +27,8 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libtiff.so:graphics/tiff \
libsodium.so:security/libsodium
-USES= compiler:c++11-lib desktop-file-utils dos2unix gmake iconv jpeg openal:al \
- pkgconfig python:2.7,build tar:xz
+USES= compiler:c++11-lib desktop-file-utils dos2unix gl gmake gnome iconv \
+ jpeg openal:al pkgconfig python:2.7,build sdl tar:xz
USE_GNOME= libxml2
USE_GL= gl
USE_SDL= sdl2
diff --git a/games/0ad/files/patch-libraries_source_fcollada_src_Makefile b/games/0ad/files/patch-libraries_source_fcollada_src_Makefile
index ed6bd804207e..5221789a8bcb 100644
--- a/games/0ad/files/patch-libraries_source_fcollada_src_Makefile
+++ b/games/0ad/files/patch-libraries_source_fcollada_src_Makefile
@@ -1,11 +1,11 @@
---- libraries/source/fcollada/src/Makefile.orig 2014-09-24 14:39:28 UTC
+--- libraries/source/fcollada/src/Makefile.orig 2019-04-26 13:27:39 UTC
+++ libraries/source/fcollada/src/Makefile
@@ -227,7 +227,7 @@ OBJECTS_ALL = $(OBJECTS_DEBUG) $(OBJECTS_RELEASE) $(OB
all: output/libFColladaSD.a output/libFColladaSR.a install
output_dirs:
- bash -c 'mkdir -p output/{debug,release,test}/{FCollada/{FCDocument,FMath,FUtils,FColladaTest/{FCTestAssetManagement,FCTestExportImport,FCTestXRef}},FColladaPlugins/FArchiveXML}'
-+ csh -c 'mkdir -p output/{debug,release,test}/{FCollada/{FCDocument,FMath,FUtils,FColladaTest/{FCTestAssetManagement,FCTestExportImport,FCTestXRef}},FColladaPlugins/FArchiveXML}'
++ for x in debug release test; do for y in FCDocument FMath FUtils FColladaTest; do for z in FCTestAssetManagement FCTestExportImport FCTestXRef; do mkdir -p output/$$x/FCollada/$$y/$$z; done; done; mkdir -p output/$$x/FColladaPlugins/FArchiveXML; done
test: FCollada/FColladaTest/ output/FColladaTest
( cd FCollada/FColladaTest/ ; ../../output/FColladaTest )