aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-12-21 18:23:19 +0800
committerlinimon <linimon@FreeBSD.org>2017-12-21 18:23:19 +0800
commit6a2c8adf9eab2d622b7805a3cb7990c8c9454251 (patch)
treee2529c5247b78282bbb3a3cc3aaaad34e48baf86 /games
parentc9983b6ed69b31349559fe4008e6b2e88fe191c7 (diff)
downloadfreebsd-ports-gnome-6a2c8adf9eab2d622b7805a3cb7990c8c9454251.tar.gz
freebsd-ports-gnome-6a2c8adf9eab2d622b7805a3cb7990c8c9454251.tar.zst
freebsd-ports-gnome-6a2c8adf9eab2d622b7805a3cb7990c8c9454251.zip
Try to bring some consistency to ports that have x86-specific pieces.
- in general, if we think that the code is not architecture-specific, and instead just enables x86 assembler by default, those should use BROKEN rather than IGNORE. This will allow them to be attempted with TRYBROKEN. - spell i386 as x86. - spell asm as assembler. - pet portlint. These changes should have no effect on tier-1 builds. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'games')
-rw-r--r--games/supertuxkart/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/games/supertuxkart/Makefile b/games/supertuxkart/Makefile
index 11cecd4be10d..81b531fc0ec1 100644
--- a/games/supertuxkart/Makefile
+++ b/games/supertuxkart/Makefile
@@ -20,8 +20,13 @@ LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
libpng.so:graphics/png \
libfreetype.so:print/freetype2
-ONLY_FOR_ARCHS= amd64 i386
-ONLY_FOR_ARCHS_REASON= fails to build: invokes x86 asm
+BROKEN_aarch64= invokes x86 assembler
+BROKEN_armv6= invokes x86 assembler
+BROKEN_armv7= invokes x86 assembler
+BROKEN_mips= invokes x86 assembler
+BROKEN_mips64= invokes x86 assembler
+BROKEN_sparc64= invokes x86 assembler
+BROKEN_powerpc64= invokes x86 assembler
USES= alias cmake compiler:c++11-lib dos2unix gettext \
jpeg openal:al pkgconfig tar:xz