aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-09-01 17:41:42 +0800
committertobik <tobik@FreeBSD.org>2018-09-01 17:41:42 +0800
commit02d1110ed7f4929e16508f886bc8f8884087325b (patch)
tree89269f3dd2a1e2edf85ccca735292ef8f834665f /games
parent816a06063541c16647c65b7b5919313a023f85c8 (diff)
downloadfreebsd-ports-gnome-02d1110ed7f4929e16508f886bc8f8884087325b.tar.gz
freebsd-ports-gnome-02d1110ed7f4929e16508f886bc8f8884087325b.tar.zst
freebsd-ports-gnome-02d1110ed7f4929e16508f886bc8f8884087325b.zip
games/rtb: Fix build with Clang 6
Structs.cc:50:5: error: constant expression evaluates to 255 which cannot be narrowed to type 'gchar' (aka 'char') [-Wc++11-narrowing] 0xff, 0x3f, 0xff, 0x3f, 0xff, 0x3f, 0xff, 0x3f, 0xff, 0x3f, 0xff, 0x3f, ^~~~ http://beefy11.nyi.freebsd.org/data/head-i386-default/p478276_s338342/logs/errors/RealTimeBattle-1.0.8_11.log
Diffstat (limited to 'games')
-rw-r--r--games/rtb/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/games/rtb/Makefile b/games/rtb/Makefile
index d64c88c31ce8..ee220720327d 100644
--- a/games/rtb/Makefile
+++ b/games/rtb/Makefile
@@ -16,11 +16,13 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= gsed:textproc/gsed
-USES= gettext gmake perl5 pkgconfig python:2.7 tar:bzip2
+USES= compiler gettext gmake perl5 pkgconfig python:2.7 tar:bzip2
USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-rtb-dir=${PREFIX}/lib/${PORTNAME}
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib