aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-09-05 22:26:40 +0800
committermadpilot <madpilot@FreeBSD.org>2013-09-05 22:26:40 +0800
commit09ced0639f84a239a7978c58ad558129143bf5d3 (patch)
tree721ca1155d5a4c52654ba4b9db2a11187d57b30b /games
parentd39ff6a176ecd484b14b0ec843f8f778881cf690 (diff)
downloadfreebsd-ports-gnome-09ced0639f84a239a7978c58ad558129143bf5d3.tar.gz
freebsd-ports-gnome-09ced0639f84a239a7978c58ad558129143bf5d3.tar.zst
freebsd-ports-gnome-09ced0639f84a239a7978c58ad558129143bf5d3.zip
- Fix build on head after iconv and new ld behavior changes
- Convert to new LIB_DEPENDS format
Diffstat (limited to 'games')
-rw-r--r--games/pokerth/Makefile15
-rw-r--r--games/pokerth/files/patch-pokerth_game.pro17
-rw-r--r--games/pokerth/files/patch-pokerth_server.pro11
3 files changed, 32 insertions, 11 deletions
diff --git a/games/pokerth/Makefile b/games/pokerth/Makefile
index ce5c3883757e..7cf12946da53 100644
--- a/games/pokerth/Makefile
+++ b/games/pokerth/Makefile
@@ -14,13 +14,13 @@ COMMENT= A poker game written in C++/QT4
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
- mikmod:${PORTSDIR}/audio/libmikmod \
- gnutls:${PORTSDIR}/security/gnutls \
- curl:${PORTSDIR}/ftp/curl \
- gsasl:${PORTSDIR}/security/gsasl \
- tinyxml:${PORTSDIR}/textproc/tinyxml \
- protobuf:${PORTSDIR}/devel/protobuf
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libmikmod.so:${PORTSDIR}/audio/libmikmod \
+ libgnutls.so:${PORTSDIR}/security/gnutls \
+ libcurl.so:${PORTSDIR}/ftp/curl \
+ libgsasl.so:${PORTSDIR}/security/gsasl \
+ libtinyxml.so:${PORTSDIR}/textproc/tinyxml \
+ libprotobuf.so:${PORTSDIR}/devel/protobuf
BUILD_DEPENDS= ${LOCALBASE}/include/libircclient.h:${PORTSDIR}/irc/libircclient
USES= iconv gmake
@@ -40,6 +40,7 @@ post-patch:
@${REINPLACE_CMD} -E \
-e 's|/usr([a-z|/]*)|${LOCALBASE}/\1|g' \
-e 's|(-lcurl)|\1 ${ICONV_LIB}|g' \
+ -e 's|(-lcrypto) -liconv|\1 ${ICONV_LIB}|' \
-e 's:boost_([a-z]+)-[-|a-z|0-9|_]*:boost_\1:g' \
-e 's|LIB_DIRS =.*|LIB_DIRS = ${LOCALBASE}/lib|g' \
-e '/.*QMAKE_CXXFLAGS.*/d' \
diff --git a/games/pokerth/files/patch-pokerth_game.pro b/games/pokerth/files/patch-pokerth_game.pro
index 84f36c1893a7..49538dd24219 100644
--- a/games/pokerth/files/patch-pokerth_game.pro
+++ b/games/pokerth/files/patch-pokerth_game.pro
@@ -1,6 +1,6 @@
---- pokerth_game.pro.orig 2012-06-21 22:54:48.000000000 +0200
-+++ pokerth_game.pro 2012-06-22 11:47:32.047160533 +0200
-@@ -392,8 +392,7 @@
+--- pokerth_game.pro.orig 2013-04-07 14:04:26.923209000 +0200
++++ pokerth_game.pro 2013-09-05 12:07:44.416793690 +0200
+@@ -407,8 +407,7 @@
LIBPATH += lib
!android{
LIBPATH += $${PREFIX}/lib /opt/gsasl/lib
@@ -10,7 +10,7 @@
}
android{
LIBPATH += $${PREFIX}/lib/armv5
-@@ -412,7 +411,7 @@
+@@ -427,7 +426,7 @@
BOOST_RANDOM = boost_random \
boost_random-mt
@@ -19,3 +19,12 @@
# to override the default '/usr' pass PREFIX
# variable to qmake.
for(dir, LIB_DIRS):exists($$dir) {
+@@ -501,7 +500,7 @@
+ LIBS += -lSDL \
+ -lSDL_mixer \
+ -lgsasl
+- !isEmpty( BSD ):isEmpty( kFreeBSD ):LIBS += -lcrypto
++ !isEmpty( BSD ):isEmpty( kFreeBSD ):LIBS += -lcrypto -lssl
+ else:LIBS += -lgcrypt
+ }
+ android{
diff --git a/games/pokerth/files/patch-pokerth_server.pro b/games/pokerth/files/patch-pokerth_server.pro
new file mode 100644
index 000000000000..6306fc6bfb2a
--- /dev/null
+++ b/games/pokerth/files/patch-pokerth_server.pro
@@ -0,0 +1,11 @@
+--- pokerth_server.pro.orig 2013-04-07 14:04:26.923209000 +0200
++++ pokerth_server.pro 2013-09-05 14:53:56.604074418 +0200
+@@ -265,7 +265,7 @@
+ -lprotobuf
+ LIBS += -lgsasl
+ !isEmpty( BSD ): isEmpty( kFreeBSD ){
+- LIBS += -lcrypto -liconv
++ LIBS += -lcrypto -liconv -lssl
+ } else {
+ LIBS += -lgcrypt
+ }