aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-06-13 07:52:44 +0800
committeraaron <aaron@FreeBSD.org>2006-06-13 07:52:44 +0800
commit1f648618f1d09ab8864d38b2508b6def3bcd14fd (patch)
tree2ac73ec7902b68eb9a7face5ddd870394ebbf3b1 /games
parentf802b13429e96e4b03e823a793071d8608c31afa (diff)
downloadfreebsd-ports-gnome-1f648618f1d09ab8864d38b2508b6def3bcd14fd.tar.gz
freebsd-ports-gnome-1f648618f1d09ab8864d38b2508b6def3bcd14fd.tar.zst
freebsd-ports-gnome-1f648618f1d09ab8864d38b2508b6def3bcd14fd.zip
Adding port games/p5-Algorithm-Pair-Swiss, Generate unique pairings for
tournaments. Approved by: tobez (implicit)
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/p5-Algorithm-Pair-Swiss/Makefile28
-rw-r--r--games/p5-Algorithm-Pair-Swiss/distinfo3
-rw-r--r--games/p5-Algorithm-Pair-Swiss/pkg-descr10
-rw-r--r--games/p5-Algorithm-Pair-Swiss/pkg-plist3
5 files changed, 45 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 6baa5dc30924..9417b85b7ad4 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -469,6 +469,7 @@
SUBDIR += openmortal
SUBDIR += openttd
SUBDIR += orbital_eunuchs_sniper
+ SUBDIR += p5-Algorithm-Pair-Swiss
SUBDIR += p5-Games-AlphaBeta
SUBDIR += p5-Games-Bingo
SUBDIR += p5-Games-Bingo-Bot
diff --git a/games/p5-Algorithm-Pair-Swiss/Makefile b/games/p5-Algorithm-Pair-Swiss/Makefile
new file mode 100644
index 000000000000..bc9f5a173a5e
--- /dev/null
+++ b/games/p5-Algorithm-Pair-Swiss/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Algorithm-Pair-Swiss
+# Date created: 12 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-Pair-Swiss
+PORTVERSION= 0.12
+CATEGORIES= games perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Generate unique pairings for tournaments
+
+MAN3= Algorithm::Pair::Swiss.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/p5-Algorithm-Pair-Swiss/distinfo b/games/p5-Algorithm-Pair-Swiss/distinfo
new file mode 100644
index 000000000000..9fe8cbdad621
--- /dev/null
+++ b/games/p5-Algorithm-Pair-Swiss/distinfo
@@ -0,0 +1,3 @@
+MD5 (Algorithm-Pair-Swiss-0.12.tar.gz) = 30bc237228b8069af33b3bd2231043fa
+SHA256 (Algorithm-Pair-Swiss-0.12.tar.gz) = d1a91bb9985f814052f08e69ed7964d350ab73fc0effffaf304c787279543ea7
+SIZE (Algorithm-Pair-Swiss-0.12.tar.gz) = 5050
diff --git a/games/p5-Algorithm-Pair-Swiss/pkg-descr b/games/p5-Algorithm-Pair-Swiss/pkg-descr
new file mode 100644
index 000000000000..90043d9c16ab
--- /dev/null
+++ b/games/p5-Algorithm-Pair-Swiss/pkg-descr
@@ -0,0 +1,10 @@
+This module was created as an alternative for Algorithm::Pair::Best, which
+probably offers more control over the pairings, in particular regarding
+ensuring the highest overal quality of pairings. Algorithm::Pair::Swiss is
+sort of dumb in this regard, but uses a slightly more intuitive interface
+and an algorithm that should perform noticably faster. The module was
+primarily designed based on the Swiss rounds system used for Magic: The
+Gathering tournaments.
+
+WWW: http://search.cpan.org/dist/Algorithm-Pair-Swiss
+Author: Gilion Goudsmit <ggoudsmit@shebang.nl>
diff --git a/games/p5-Algorithm-Pair-Swiss/pkg-plist b/games/p5-Algorithm-Pair-Swiss/pkg-plist
new file mode 100644
index 000000000000..fb2024fb91cb
--- /dev/null
+++ b/games/p5-Algorithm-Pair-Swiss/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Algorithm/Pair/Swiss.pm
+@dirrmtry %%SITE_PERL%%/Algorithm/Pair
+@dirrmtry %%SITE_PERL%%/Algorithm