aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-12-03 21:38:48 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-12-03 21:38:48 +0800
commit2ad15574c85a9cb354b1609646c14ee0b2ca809b (patch)
treeff2a544fb3b840f9364df3e385255297608d4f59 /games
parentb58d720ea57c4bb632fb55c3940c37664d654633 (diff)
downloadfreebsd-ports-gnome-2ad15574c85a9cb354b1609646c14ee0b2ca809b.tar.gz
freebsd-ports-gnome-2ad15574c85a9cb354b1609646c14ee0b2ca809b.tar.zst
freebsd-ports-gnome-2ad15574c85a9cb354b1609646c14ee0b2ca809b.zip
- Remove NLS option, doesn't build with it disabled
- Fix etc/ggz.modules handling - Drop @dirrm* from plist
Diffstat (limited to 'games')
-rw-r--r--games/ggz-gtk-games/Makefile9
-rw-r--r--games/ggz-gtk-games/pkg-plist41
2 files changed, 13 insertions, 37 deletions
diff --git a/games/ggz-gtk-games/Makefile b/games/ggz-gtk-games/Makefile
index 05d787df5397..279b1b0198ef 100644
--- a/games/ggz-gtk-games/Makefile
+++ b/games/ggz-gtk-games/Makefile
@@ -11,7 +11,7 @@ COMMENT= The GGZ Gaming Zone - GTK+ Games
RUN_DEPENDS= ${LOCALBASE}/bin/ggz-gtk:${PORTSDIR}/games/ggz-gtk-client
-USES= pkgconfig
+USES= gettext pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-debug
@@ -22,12 +22,6 @@ INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -pthread
-OPTIONS_DEFINE= NLS
-OPTIONS_SUB= yes
-
-NLS_USES= gettext
-NLS_CONFIGURE_OFF= --disable-nls
-
post-patch:
@${REINPLACE_CMD} -e 's|_LDADD =|_LDADD = -lggzcore|' \
${WRKSRC}/chess/Makefile.in \
@@ -50,6 +44,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/reversi/module.dsc ${STAGEDIR}/${PREFIX}/share/ggz/reversi.dsc
${INSTALL_DATA} ${WRKSRC}/spades/module.dsc ${STAGEDIR}/${PREFIX}/share/ggz/spades.dsc
${INSTALL_DATA} ${WRKSRC}/tictactoe/module.dsc ${STAGEDIR}/${PREFIX}/share/ggz/tictactoe.dsc
+ ${RM} ${STAGEDIR}${PREFIX}/etc/ggz.modules
.include "${.CURDIR}/../libggz/bsd.ggz.mk"
.include <bsd.port.mk>
diff --git a/games/ggz-gtk-games/pkg-plist b/games/ggz-gtk-games/pkg-plist
index 8930d47ee379..dabe07796548 100644
--- a/games/ggz-gtk-games/pkg-plist
+++ b/games/ggz-gtk-games/pkg-plist
@@ -125,33 +125,14 @@ share/ggz/spades.dsc
@unexec ggz-config -D --remove --modfile=%D/share/ggz/tictactoe.dsc --force
share/ggz/tictactoe.dsc
@exec ggz-config -D --install --modfile=%D/share/ggz/tictactoe.dsc --force
-%%NLS%%share/locale/de/LC_MESSAGES/chess.mo
-%%NLS%%share/locale/de/LC_MESSAGES/chinese-checkers.mo
-%%NLS%%share/locale/de/LC_MESSAGES/combat.mo
-%%NLS%%share/locale/de/LC_MESSAGES/common.mo
-%%NLS%%share/locale/de/LC_MESSAGES/dots.mo
-%%NLS%%share/locale/de/LC_MESSAGES/ggzcards.mo
-%%NLS%%share/locale/de/LC_MESSAGES/hastings.mo
-%%NLS%%share/locale/de/LC_MESSAGES/reversi.mo
-%%NLS%%share/locale/de/LC_MESSAGES/spades.mo
-%%NLS%%share/locale/de/LC_MESSAGES/tictactoe.mo
-@dirrm share/ggz/tictactoe/pixmaps
-@dirrm share/ggz/tictactoe
-@dirrm share/ggz/reversi/pixmaps
-@dirrm share/ggz/reversi
-@dirrm share/ggz/pixmaps
-@dirrm share/ggz/hastings/pixmaps
-@dirrm share/ggz/hastings
-@dirrm share/ggz/combat/pixmaps/default
-@dirrm share/ggz/combat/pixmaps
-@dirrm share/ggz/combat/maps
-@dirrm share/ggz/combat
-@dirrm share/ggz/chess/pixmaps
-@dirrm share/ggz/chess
-@dirrm share/ggz/ccheckers/pixmaps/templates
-@dirrm share/ggz/ccheckers/pixmaps/default
-@dirrm share/ggz/ccheckers/pixmaps/Electric
-@dirrm share/ggz/ccheckers/pixmaps/Dragon
-@dirrm share/ggz/ccheckers/pixmaps
-@dirrm share/ggz/ccheckers
-@dirrmtry lib/ggz
+share/locale/de/LC_MESSAGES/chess.mo
+share/locale/de/LC_MESSAGES/chinese-checkers.mo
+share/locale/de/LC_MESSAGES/combat.mo
+share/locale/de/LC_MESSAGES/common.mo
+share/locale/de/LC_MESSAGES/dots.mo
+share/locale/de/LC_MESSAGES/ggzcards.mo
+share/locale/de/LC_MESSAGES/hastings.mo
+share/locale/de/LC_MESSAGES/reversi.mo
+share/locale/de/LC_MESSAGES/spades.mo
+share/locale/de/LC_MESSAGES/tictactoe.mo
+@unexec if [ "x`cat %D/etc/ggz.modules`" = "x[Games]" ]; then echo -n > %D/etc/ggz.modules; fi