aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-04-25 05:01:54 +0800
committeralepulver <alepulver@FreeBSD.org>2006-04-25 05:01:54 +0800
commit2b3b55c4d4d5b854fd7f08d7289a59b8a1f7bd31 (patch)
tree68e969c9d9b0252d116c5a810e781e2b2476f13f /games
parent5376d6f10a2716fb705d10fcb4936ef33cd8ea05 (diff)
downloadfreebsd-ports-gnome-2b3b55c4d4d5b854fd7f08d7289a59b8a1f7bd31.tar.gz
freebsd-ports-gnome-2b3b55c4d4d5b854fd7f08d7289a59b8a1f7bd31.tar.zst
freebsd-ports-gnome-2b3b55c4d4d5b854fd7f08d7289a59b8a1f7bd31.zip
- Remove USE_REINPLACE.
- Format tabs. - Fix OPTIONS handling. - Bump PORTREVISION. Approved by: garga (mentor)
Diffstat (limited to 'games')
-rw-r--r--games/bomns/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/games/bomns/Makefile b/games/bomns/Makefile
index a1da53b9f9cb..6b24e670b797 100644
--- a/games/bomns/Makefile
+++ b/games/bomns/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bomns
PORTVERSION= 0.99.1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= greenridge
@@ -17,7 +18,6 @@ COMMENT= The best old-school deathmatch game EVER (only for two players)
USE_BZIP2= yes
USE_SDL= mixer sdl
WANT_GNOME= yes
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags`" \
@@ -30,38 +30,38 @@ OPTIONS= EDITOR "Enable building of the map editor" on \
.include <bsd.port.pre.mk>
-.if defined(WITH_EDITOR)
+.if !defined(WITHOUT_EDITOR)
PLIST_SUB+= EDITOR=""
.else
-CONFIGURE_ARGS+= --disable-editor
+CONFIGURE_ARGS+=--disable-editor
PLIST_SUB+= EDITOR="@comment "
.endif
-.if defined(WITH_LAUNCHER)
+.if !defined(WITHOUT_LAUNCHER)
USE_GNOME= gtk20
PLIST_SUB+= LAUNCHER=""
.else
-CONFIGURE_ARGS+= --disable-launcher2
+CONFIGURE_ARGS+=--disable-launcher2
PLIST_SUB+= LAUNCHER="@comment "
.endif
post-patch:
-# Fix SDL include statement
+# Fix SDL include statement.
.for f in *.cpp *.h
@${FIND} ${WRKSRC}/src -type f -name ${f} -print0 | \
${XARGS} -0 \
${REINPLACE_CMD} -e 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|'
.endfor
-# Remove -lSDL linker flag
+# Remove -lSDL linker flag.
.for f in Makefile.am Makefile.in
@${FIND} ${WRKSRC}/src -type f -name ${f} -print0 | \
${XARGS} -0 \
${REINPLACE_CMD} -e 's|-lSDL || ; s|-lSDL$$|| ; s|-lpthread||'
.endfor
-# Enable/disable compilation optimizations
-.if !defined(WITH_OPTIMIZED_CFLAGS)
+# Enable/disable compilation optimizations.
+.if defined(WITHOUT_OPTIMIZED_CFLAGS)
@${REINPLACE_CMD} -e 's|-O2||' ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.endif