aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-08-09 15:23:53 +0800
committervs <vs@FreeBSD.org>2004-08-09 15:23:53 +0800
commit2fb38a108cc9b57dd79564cfd5d506df61bf36f8 (patch)
tree143b13b862440a8c4e8474d6dc9f5d29352594e1 /games
parentdc8290e79167803472cc7ced75fa1302ec4c5af3 (diff)
downloadfreebsd-ports-gnome-2fb38a108cc9b57dd79564cfd5d506df61bf36f8.tar.gz
freebsd-ports-gnome-2fb38a108cc9b57dd79564cfd5d506df61bf36f8.tar.zst
freebsd-ports-gnome-2fb38a108cc9b57dd79564cfd5d506df61bf36f8.zip
Update to 0.8.1.30
PR: ports/70020 Submitted by: Stefan Walter (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/gnocatan/Makefile3
-rw-r--r--games/gnocatan/distinfo4
-rw-r--r--games/gnocatan/files/patch-client_gtk_trade.c56
-rw-r--r--games/gnocatan/pkg-descr2
-rw-r--r--games/pioneers/Makefile3
-rw-r--r--games/pioneers/distinfo4
-rw-r--r--games/pioneers/files/patch-client_gtk_trade.c56
-rw-r--r--games/pioneers/pkg-descr2
8 files changed, 118 insertions, 12 deletions
diff --git a/games/gnocatan/Makefile b/games/gnocatan/Makefile
index ca3e4259db59..111dd465250f 100644
--- a/games/gnocatan/Makefile
+++ b/games/gnocatan/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnocatan
-PORTVERSION= 0.8.1.16
-PORTREVISION= 1
+PORTVERSION= 0.8.1.30
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/games/gnocatan/distinfo b/games/gnocatan/distinfo
index 1bc98550b246..085237671b37 100644
--- a/games/gnocatan/distinfo
+++ b/games/gnocatan/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnocatan-0.8.1.16.tar.gz) = 9dd31aad77a44ed2e3e8ba6c39e5aa7e
-SIZE (gnocatan-0.8.1.16.tar.gz) = 2116705
+MD5 (gnocatan-0.8.1.30.tar.gz) = 3ea69eb647eea4173979293d24d81f54
+SIZE (gnocatan-0.8.1.30.tar.gz) = 2053826
diff --git a/games/gnocatan/files/patch-client_gtk_trade.c b/games/gnocatan/files/patch-client_gtk_trade.c
new file mode 100644
index 000000000000..0b78b874ec4e
--- /dev/null
+++ b/games/gnocatan/files/patch-client_gtk_trade.c
@@ -0,0 +1,56 @@
+--- client/gtk/trade.c.orig Fri Aug 6 14:40:41 2004
++++ client/gtk/trade.c Fri Aug 6 14:44:54 2004
+@@ -197,16 +197,16 @@
+ static void load_pixmaps(void)
+ {
+ static gboolean init = FALSE;
++ int width, height;
++ GdkGC *gc;
++ GdkPixmap *pixmap;
++ gint i;
+
+ if (init) return;
+
+- int width, height;
+ gtk_icon_size_lookup(GTK_ICON_SIZE_MENU, &width, &height);
+
+- GdkPixmap *pixmap;
+ pixmap = gdk_pixmap_new(quotes->window, width, height, gtk_widget_get_visual(quotes)->depth);
+- GdkGC *gc;
+- gint i;
+
+ gc = gdk_gc_new(pixmap);
+ gdk_gc_set_foreground(gc, &black);
+@@ -349,6 +349,7 @@
+ QuoteInfo *quote;
+ QuoteInfo *prev;
+ gchar quote_desc[128];
++ GtkTreeIter iter;
+
+ for (quote = quotelist_first(quote_list);
+ quote != NULL; quote = quotelist_next(quote))
+@@ -364,7 +365,6 @@
+ trade_format_maritime(quote, quote_desc);
+ prev = quotelist_prev(quote);
+
+- GtkTreeIter iter;
+ quote_found_flag = FALSE;
+ if (prev != NULL)
+ gtk_tree_model_foreach(GTK_TREE_MODEL(store), trade_locate_quote, prev);
+@@ -536,6 +536,7 @@
+ static void add_trade_row(GtkWidget *table, TradeRow* row, Resource resource)
+ {
+ GtkWidget *label;
++ GtkWidget *frame;
+ gint col;
+
+ col = 0;
+@@ -549,7 +550,7 @@
+ col++;
+
+ /* Draw a border around the number */
+- GtkWidget *frame = gtk_viewport_new(NULL, NULL);
++ frame = gtk_viewport_new(NULL, NULL);
+ gtk_viewport_set_shadow_type(GTK_VIEWPORT(frame), GTK_SHADOW_IN);
+ gtk_widget_show(frame);
+ gtk_table_attach(GTK_TABLE(table), frame,
diff --git a/games/gnocatan/pkg-descr b/games/gnocatan/pkg-descr
index 63fab087e88a..bb98e722fa77 100644
--- a/games/gnocatan/pkg-descr
+++ b/games/gnocatan/pkg-descr
@@ -3,5 +3,3 @@ Catan board game. The aim is to remain as faithful to the board game
as is possible.
WWW: http://gnocatan.sourceforge.net/
-
--Adam <adam-ports@blacktabby.org>
diff --git a/games/pioneers/Makefile b/games/pioneers/Makefile
index ca3e4259db59..111dd465250f 100644
--- a/games/pioneers/Makefile
+++ b/games/pioneers/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnocatan
-PORTVERSION= 0.8.1.16
-PORTREVISION= 1
+PORTVERSION= 0.8.1.30
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/games/pioneers/distinfo b/games/pioneers/distinfo
index 1bc98550b246..085237671b37 100644
--- a/games/pioneers/distinfo
+++ b/games/pioneers/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnocatan-0.8.1.16.tar.gz) = 9dd31aad77a44ed2e3e8ba6c39e5aa7e
-SIZE (gnocatan-0.8.1.16.tar.gz) = 2116705
+MD5 (gnocatan-0.8.1.30.tar.gz) = 3ea69eb647eea4173979293d24d81f54
+SIZE (gnocatan-0.8.1.30.tar.gz) = 2053826
diff --git a/games/pioneers/files/patch-client_gtk_trade.c b/games/pioneers/files/patch-client_gtk_trade.c
new file mode 100644
index 000000000000..0b78b874ec4e
--- /dev/null
+++ b/games/pioneers/files/patch-client_gtk_trade.c
@@ -0,0 +1,56 @@
+--- client/gtk/trade.c.orig Fri Aug 6 14:40:41 2004
++++ client/gtk/trade.c Fri Aug 6 14:44:54 2004
+@@ -197,16 +197,16 @@
+ static void load_pixmaps(void)
+ {
+ static gboolean init = FALSE;
++ int width, height;
++ GdkGC *gc;
++ GdkPixmap *pixmap;
++ gint i;
+
+ if (init) return;
+
+- int width, height;
+ gtk_icon_size_lookup(GTK_ICON_SIZE_MENU, &width, &height);
+
+- GdkPixmap *pixmap;
+ pixmap = gdk_pixmap_new(quotes->window, width, height, gtk_widget_get_visual(quotes)->depth);
+- GdkGC *gc;
+- gint i;
+
+ gc = gdk_gc_new(pixmap);
+ gdk_gc_set_foreground(gc, &black);
+@@ -349,6 +349,7 @@
+ QuoteInfo *quote;
+ QuoteInfo *prev;
+ gchar quote_desc[128];
++ GtkTreeIter iter;
+
+ for (quote = quotelist_first(quote_list);
+ quote != NULL; quote = quotelist_next(quote))
+@@ -364,7 +365,6 @@
+ trade_format_maritime(quote, quote_desc);
+ prev = quotelist_prev(quote);
+
+- GtkTreeIter iter;
+ quote_found_flag = FALSE;
+ if (prev != NULL)
+ gtk_tree_model_foreach(GTK_TREE_MODEL(store), trade_locate_quote, prev);
+@@ -536,6 +536,7 @@
+ static void add_trade_row(GtkWidget *table, TradeRow* row, Resource resource)
+ {
+ GtkWidget *label;
++ GtkWidget *frame;
+ gint col;
+
+ col = 0;
+@@ -549,7 +550,7 @@
+ col++;
+
+ /* Draw a border around the number */
+- GtkWidget *frame = gtk_viewport_new(NULL, NULL);
++ frame = gtk_viewport_new(NULL, NULL);
+ gtk_viewport_set_shadow_type(GTK_VIEWPORT(frame), GTK_SHADOW_IN);
+ gtk_widget_show(frame);
+ gtk_table_attach(GTK_TABLE(table), frame,
diff --git a/games/pioneers/pkg-descr b/games/pioneers/pkg-descr
index 63fab087e88a..bb98e722fa77 100644
--- a/games/pioneers/pkg-descr
+++ b/games/pioneers/pkg-descr
@@ -3,5 +3,3 @@ Catan board game. The aim is to remain as faithful to the board game
as is possible.
WWW: http://gnocatan.sourceforge.net/
-
--Adam <adam-ports@blacktabby.org>