aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-11-17 11:56:20 +0800
committerdanilo <danilo@FreeBSD.org>2013-11-17 11:56:20 +0800
commit3c104bc8e02d23da4f082622bdebd29ec38df56a (patch)
treec2ac2d5417f8d4eb08b82d3c6c5b09dc9bf4bdfb /games
parent42b5b1772c91574a557ee265b4af52bda21bfec7 (diff)
downloadfreebsd-ports-gnome-3c104bc8e02d23da4f082622bdebd29ec38df56a.tar.gz
freebsd-ports-gnome-3c104bc8e02d23da4f082622bdebd29ec38df56a.tar.zst
freebsd-ports-gnome-3c104bc8e02d23da4f082622bdebd29ec38df56a.zip
- Remove NO_PACKAGE
- Add DOCS option - Add stage support
Diffstat (limited to 'games')
-rw-r--r--games/linux-enemyterritory-tce/Makefile22
1 files changed, 7 insertions, 15 deletions
diff --git a/games/linux-enemyterritory-tce/Makefile b/games/linux-enemyterritory-tce/Makefile
index 57715f5e222e..92a29499a1c6 100644
--- a/games/linux-enemyterritory-tce/Makefile
+++ b/games/linux-enemyterritory-tce/Makefile
@@ -18,11 +18,12 @@ RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
ONLY_FOR_ARCHS= i386 amd64
USE_ZIP= yes
USE_LINUX= yes
-NO_PACKAGE= Distfile size is 450MB, set FORCE_PACKAGE if you really want to build this package
RESTRICTED= Redistribution is limited, see license
ETDIR= ${PREFIX}/lib/enemyterritory
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
DESKTOP_ENTRIES="Enemy Territory TrueCombat:Elite" \
"Play Enemy Territory TrueCombat:Elite" \
"${ETDIR}/tcetest/tce_icon_pc.ico" \
@@ -30,7 +31,6 @@ DESKTOP_ENTRIES="Enemy Territory TrueCombat:Elite" \
"" \
false
-NO_STAGE= yes
do-build:
.for f in et etded
@${ECHO_CMD} '#!/bin/sh' > ${WRKSRC}/${f}-tce
@@ -39,25 +39,17 @@ do-build:
do-install:
.for f in et etded
- ${INSTALL_SCRIPT} ${WRKSRC}/${f}-tce ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f}-tce ${STAGEDIR}${PREFIX}/bin
.endfor
-
- ${MKDIR} ${ETDIR}/tcetest
+ @${MKDIR} ${STAGEDIR}${ETDIR}/tcetest
.for f in autoexec.cfg cgame.mp.i386.so mp_bin.pk3 official.dat pak0.pk3 \
pak1.pk3 pak2.pk3 pak3.pk3 qagame.mp.i386.so tce_icon_pc.ico \
ui.mp.i386.so
- ${INSTALL_DATA} ${WRKSRC}/${f} ${ETDIR}/tcetest
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${ETDIR}/tcetest
.endfor
-.for f in cgame.mp.i386.so qagame.mp.i386.so ui.mp.i386.so
- -${CHOWN} ${LIBOWN}:${LIBGRP} ${ETDIR}/tcetest/${f}
- ${CHMOD} ${LIBMODE} ${ETDIR}/tcetest/${f}
-.endfor
-
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in *.txt *.rtf
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>