aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-12-29 10:17:40 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-12-29 10:17:40 +0800
commit493d030c39969d4c6b5735938dfc0208a6e374d8 (patch)
tree93fa95d73cd4e1887c98cac1e2672055dc9eed58 /games
parentcce800ccfe038dc88c38578f8f423bc710ad9805 (diff)
downloadfreebsd-ports-gnome-493d030c39969d4c6b5735938dfc0208a6e374d8.tar.gz
freebsd-ports-gnome-493d030c39969d4c6b5735938dfc0208a6e374d8.tar.zst
freebsd-ports-gnome-493d030c39969d4c6b5735938dfc0208a6e374d8.zip
- Fix build with newer cmake
PR: 141410 Submitted by: Barbara <barbara.xxx1975@libero.it>
Diffstat (limited to 'games')
-rw-r--r--games/vavoom/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index 2b23394f61c9..0e8fb8f207dc 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -33,8 +33,6 @@ OPTIONS= ALLEGRO "Use Allegro for hardware API" off \
SUB_FILES= pkg-message
-BROKEN= fails to build with new cmake.
-
.include <bsd.port.pre.mk>
# The `-fno-strict-aliasing' flag (default on FreeBSD 6.0+) produces
@@ -137,6 +135,19 @@ post-patch:
@${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' \
${WRKSRC}/utils/acc/strlist.c
+.if defined(WITH_LAUNCHER)
+ @${REINPLACE_CMD} -e '/add_definitions($${wxWidgets_DEFINITIONS})/d; \
+ s/include_directories($${wxWidgets_INCLUDE_DIRS})/include($${wxWidgets_USE_FILE})/' \
+ ${WRKSRC}/utils/vlaunch/CMakeLists.txt
+.endif
+
+post-configure:
+.if defined(WITH_LAUNCHER)
+ @${REINPLACE_CMD} -e 's/-pthread;-D_THREAD_SAFE //; \
+ s/-isystem /-I/g' \
+ ${WRKSRC}/utils/vlaunch/CMakeFiles/vlaunch.dir/flags.make
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}