aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2003-05-10 15:03:07 +0800
committeranholt <anholt@FreeBSD.org>2003-05-10 15:03:07 +0800
commit7c7c45583733df14165056f04517240a01b57f5c (patch)
tree6cc2508f21b18eb4408b30b67a9934aa99f6ad87 /games
parentcc33b9e5a829130b5f606667b4729bae7af9f7e3 (diff)
downloadfreebsd-ports-gnome-7c7c45583733df14165056f04517240a01b57f5c.tar.gz
freebsd-ports-gnome-7c7c45583733df14165056f04517240a01b57f5c.tar.zst
freebsd-ports-gnome-7c7c45583733df14165056f04517240a01b57f5c.zip
Convert to use USE_GETOPT_LONG
PR: ports/51858 Submitted by: Ports Fury
Diffstat (limited to 'games')
-rw-r--r--games/phalanx/Makefile5
-rw-r--r--games/phalanx/files/patch-aa23
2 files changed, 3 insertions, 25 deletions
diff --git a/games/phalanx/Makefile b/games/phalanx/Makefile
index 06f84c879e5a..d330f966e999 100644
--- a/games/phalanx/Makefile
+++ b/games/phalanx/Makefile
@@ -14,10 +14,11 @@ MASTER_SITES= ftp://ftp.math.muni.cz/pub/math/people/Dobes/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Xboard-compatible chess playing program
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-
WRKSRC= ${WRKDIR}/Phalanx-XXII
+
+USE_GETOPT_LONG= yes
USE_GMAKE= yes
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} ${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
ALL_TARGET= # empty
MAKEFILE= makefile
diff --git a/games/phalanx/files/patch-aa b/games/phalanx/files/patch-aa
deleted file mode 100644
index c512328124cb..000000000000
--- a/games/phalanx/files/patch-aa
+++ /dev/null
@@ -1,23 +0,0 @@
---- makefile.orig Mon Jan 17 06:30:49 2000
-+++ makefile Thu Mar 30 01:42:40 2000
-@@ -1,9 +1,9 @@
-
--CC = gcc
-+CC ?= gcc
-
- ####### choose the line that makes the binary faster on your machine
- # CFLAGS = -O3 -Wall -fomit-frame-pointer -funroll-loops
--CFLAGS = -O -Wall -fomit-frame-pointer
-+CFLAGS += -I${LOCALBASE}/include
-
- ####### debug/tuning options for developers
- # CFLAGS = -O -Wall -g3 -static
-@@ -21,7 +21,7 @@
- ### -DQCAPSONLY
-
- DEFINES = -DGNUFUN
--LDFLAGS =
-+LDFLAGS = -L${LOCALBASE}/lib -lgnugetopt
-
- OBJ = .o/phalanx.o .o/bcreate.o .o/search.o .o/io.o .o/data.o \
- .o/evaluate.o .o/genmoves.o .o/moving.o .o/hash.o .o/static.o \