aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2005-06-10 21:31:30 +0800
committerlawrance <lawrance@FreeBSD.org>2005-06-10 21:31:30 +0800
commitb6ca5bc1907c1bf835938810faa7e2e5e4db34ab (patch)
tree1badf698a0d4d155bb051ae8e0075bc99af44668 /games
parente1d62643447e4e5228e83ccac29779b58114271e (diff)
downloadfreebsd-ports-gnome-b6ca5bc1907c1bf835938810faa7e2e5e4db34ab.tar.gz
freebsd-ports-gnome-b6ca5bc1907c1bf835938810faa7e2e5e4db34ab.tar.zst
freebsd-ports-gnome-b6ca5bc1907c1bf835938810faa7e2e5e4db34ab.zip
BROKEN on sparc64, does not compile
PR: ports/82112 Submitted by: Thomas Vogt <thomas@bsdunix.ch> (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/foobillard/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/foobillard/Makefile b/games/foobillard/Makefile
index 5788ec9a2bdc..25fe221841f3 100644
--- a/games/foobillard/Makefile
+++ b/games/foobillard/Makefile
@@ -17,6 +17,12 @@ COMMENT= A free OpenGL-billard game
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
freetype.9:${PORTSDIR}/print/freetype2
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= "does not compile on sparc64"
+.endif
+
FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
USE_GETOPT_LONG=yes
@@ -63,4 +69,4 @@ post-patch:
post-install:
@${INSTALL_MAN} ${WRKSRC}/foobillard.6 ${PREFIX}/man/man6/foobillard.6
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>