aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-09-18 14:34:54 +0800
committermadpilot <madpilot@FreeBSD.org>2013-09-18 14:34:54 +0800
commitc17ab42d308161ac27f4b20524966dcd0ca8635d (patch)
treed50e487a542b8eb63deaff7f3ff7eede77bdd185 /games
parentcc23f8a9ae262f18ce43157f9b14c5290d0a48c9 (diff)
downloadfreebsd-ports-gnome-c17ab42d308161ac27f4b20524966dcd0ca8635d.tar.gz
freebsd-ports-gnome-c17ab42d308161ac27f4b20524966dcd0ca8635d.tar.zst
freebsd-ports-gnome-c17ab42d308161ac27f4b20524966dcd0ca8635d.zip
Fix build with libc++.
Diffstat (limited to 'games')
-rw-r--r--games/corsix-th/Makefile3
-rw-r--r--games/corsix-th/files/patch-CorsixTH-Src-iso_fs.cpp10
2 files changed, 12 insertions, 1 deletions
diff --git a/games/corsix-th/Makefile b/games/corsix-th/Makefile
index be8efd10efe9..5d17e315383d 100644
--- a/games/corsix-th/Makefile
+++ b/games/corsix-th/Makefile
@@ -20,7 +20,8 @@ USES= cmake pkgconfig
USE_LUA= yes
USE_SDL= mixer
USE_DOS2UNIX= CMake/FindFFmpeg.cmake \
- CorsixTH/CMakeLists.txt
+ CorsixTH/CMakeLists.txt \
+ CorsixTH/Src/iso_fs.cpp
OPTIONS_DEFINE= MOVIES
OPTIONS_DEFAULT= MOVIES
diff --git a/games/corsix-th/files/patch-CorsixTH-Src-iso_fs.cpp b/games/corsix-th/files/patch-CorsixTH-Src-iso_fs.cpp
new file mode 100644
index 000000000000..486c33b6f042
--- /dev/null
+++ b/games/corsix-th/files/patch-CorsixTH-Src-iso_fs.cpp
@@ -0,0 +1,10 @@
+--- CorsixTH/Src/iso_fs.cpp.orig 2013-09-17 17:59:28.434946572 +0200
++++ CorsixTH/Src/iso_fs.cpp 2013-09-17 18:00:15.533944173 +0200
+@@ -30,6 +30,7 @@
+ #ifdef CORSIX_TH_HAS_ALLOCA_H
+ #include <alloca.h>
+ #endif
++#include <cstdlib>
+ #include <algorithm>
+
+ IsoFilesystem::IsoFilesystem()