aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-05-22 06:23:08 +0800
committerlofi <lofi@FreeBSD.org>2004-05-22 06:23:08 +0800
commitd1252614215048e822b94df6cd1e90a8767f993e (patch)
tree22bd2f5189af01a1fe3bdbd91ee107fd761f6d72 /games
parent695e0248a64772c504f0bbe819b884fc235f7ebc (diff)
downloadfreebsd-ports-gnome-d1252614215048e822b94df6cd1e90a8767f993e.tar.gz
freebsd-ports-gnome-d1252614215048e822b94df6cd1e90a8767f993e.tar.zst
freebsd-ports-gnome-d1252614215048e822b94df6cd1e90a8767f993e.zip
Remove inclusion of "${PORTSDIR}/x11/kde3/Makefile.kde", fix PTHREAD_LIBS
safeness, fix compilation where needed. Committers: Please do NOT include Makefile.kde or commit new ports which do so. It's for use with the core KDE ports maintained by kde@freebsd.org ONLY.
Diffstat (limited to 'games')
-rw-r--r--games/easysok/Makefile9
-rw-r--r--games/easysok/files/patch-src_Makefile.in11
-rw-r--r--games/kslide/Makefile9
-rw-r--r--games/taxipilot/Makefile15
4 files changed, 28 insertions, 16 deletions
diff --git a/games/easysok/Makefile b/games/easysok/Makefile
index 2f46d7e8c829..53a140cbd0d2 100644
--- a/games/easysok/Makefile
+++ b/games/easysok/Makefile
@@ -17,7 +17,10 @@ COMMENT= A sokoban game for KDE3
USE_KDELIBS_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/games/easysok/files/patch-src_Makefile.in b/games/easysok/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..9d358467dec9
--- /dev/null
+++ b/games/easysok/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Fri May 21 22:37:02 2004
++++ src/Makefile.in Fri May 21 22:37:18 2004
+@@ -248,7 +248,7 @@
+
+ easysok_SOURCES = dummy.cpp
+ easysok_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+-easysok_LDADD = easysok.la $(LIB_KDEUI) $(LIB_KFILE) $(LIB_KIO) $(LIB_MNG) -lkdeprint
++easysok_LDADD = easysok.la $(LIB_KDEUI) $(LIB_KFILE) $(LIB_KIO) $(LIB_MNG) -lkdeprint $(LIBPTHREAD)
+
+ easysok_la_SOURCES = atomic_move.cpp move.cpp movements.cpp hash.cpp map.cpp \
+ compressed_map.cpp level.cpp collection.cpp collection_holder.cpp \
diff --git a/games/kslide/Makefile b/games/kslide/Makefile
index 11fb8f08ed60..7f34f1a6a83a 100644
--- a/games/kslide/Makefile
+++ b/games/kslide/Makefile
@@ -18,7 +18,10 @@ COMMENT= KDE puzzle game
USE_BZIP2= yes
USE_KDELIBS_VER= 3
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/games/taxipilot/Makefile b/games/taxipilot/Makefile
index 40427838a044..67ef0236c831 100644
--- a/games/taxipilot/Makefile
+++ b/games/taxipilot/Makefile
@@ -19,16 +19,11 @@ LIB_DEPENDS= artsmodules.0:${PORTSDIR}/multimedia/kdemultimedia3
USE_KDELIBS_VER= 3
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_AUTOCONF_VER= 253
-USE_AUTOHEADER= yes
-MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
- AUTOHEADER="${TRUE}"
-
-.include <bsd.port.pre.mk>
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
post-patch:
- @${REINPLACE_CMD} -e 's| -pedantic||g ; \
- s|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>