aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2012-05-15 07:59:03 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2012-05-15 07:59:03 +0800
commiteae1272e2e0a891354ca98f6d2f644033e2e3b62 (patch)
tree7ccf9a14b68ae5065c775e22cceede140d5324f6 /games
parent214cdaa07f0144f6ef060b4b371db78a651d8b4b (diff)
downloadfreebsd-ports-gnome-eae1272e2e0a891354ca98f6d2f644033e2e3b62.tar.gz
freebsd-ports-gnome-eae1272e2e0a891354ca98f6d2f644033e2e3b62.tar.zst
freebsd-ports-gnome-eae1272e2e0a891354ca98f6d2f644033e2e3b62.zip
Tanglet is a single player word finding game based on Boggle. The
object of the game is to list as many words as you can before the time runs out. There are several timer modes that determine how much time you start with, and if you get extra time when you find a word. You can join letters horizontally, vertically, or diagonally in any direction to make a word, so as long as the letters are next to each other on the board. However, you can not reuse the same letter cells in a single word. Also, each word must be at least three letters on a normal board, and four letters on a large board. WWW: http://gottcode.org/tanglet/ PR: 167239 Submitted by: nemysis <nemysis@gmx.ch>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/tanglet/Makefile61
-rw-r--r--games/tanglet/distinfo2
-rw-r--r--games/tanglet/pkg-descr13
-rw-r--r--games/tanglet/pkg-plist33
5 files changed, 110 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 1086cc46d40d..108742c2e061 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -856,6 +856,7 @@
SUBDIR += sxsame
SUBDIR += tads
SUBDIR += taipan
+ SUBDIR += tanglet
SUBDIR += tank
SUBDIR += taxipilot
SUBDIR += tbclock
diff --git a/games/tanglet/Makefile b/games/tanglet/Makefile
new file mode 100644
index 000000000000..498037e944a6
--- /dev/null
+++ b/games/tanglet/Makefile
@@ -0,0 +1,61 @@
+# New Ports collection makefile for: tanglet
+# Date created: 2012-04-21
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= tanglet
+PORTVERSION= 1.2.1
+CATEGORIES= games
+MASTER_SITES= http://gottcode.org/${PORTNAME}/
+EXTRACT_SUFX= -src.tar.bz2
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Tanglet is a single player word finding game based on Boggle
+
+LICENSE= GPLv3
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= moc_build qmake_build rcc_build corelib gui iconengines imageformats
+INSTALLS_ICONS= yes
+
+MAKE_JOBS_SAFE= yes
+
+PORTDATA= *
+PORTDOCS= CREDITS ChangeLog INSTALL
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} ${QMAKEFLAGS}
+
+do-install:
+# Executable
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+# Icons
+ cd ${WRKSRC}/icons && ${FIND} hicolor -type d -name apps -exec \
+ ${MKDIR} ${PREFIX}/share/icons/{} \;
+ cd ${WRKSRC}/icons && ${FIND} hicolor -type f -exec \
+ ${INSTALL_DATA} {} ${PREFIX}/share/icons/{} \;
+
+# Pixmaps and Desktop
+ ${INSTALL_DATA} ${WRKSRC}/icons/${PORTNAME}_32.xpm ${PREFIX}/share/pixmaps/
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/icons/${PORTNAME}.desktop ${PREFIX}/share/applications/
+
+# Data
+.if !defined(NOPORTDATA)
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "data translations" ${DATADIR})
+.endif
+
+# Documentation
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/tanglet/distinfo b/games/tanglet/distinfo
new file mode 100644
index 000000000000..6f29627f8a65
--- /dev/null
+++ b/games/tanglet/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tanglet-1.2.1-src.tar.bz2) = 94f4c5c76020ec1fe502ff076fbe5471e497d4b7bcabd1e9059e1022d1ce80c8
+SIZE (tanglet-1.2.1-src.tar.bz2) = 7814483
diff --git a/games/tanglet/pkg-descr b/games/tanglet/pkg-descr
new file mode 100644
index 000000000000..489920ab3b91
--- /dev/null
+++ b/games/tanglet/pkg-descr
@@ -0,0 +1,13 @@
+Tanglet is a single player word finding game based on Boggle. The
+object of the game is to list as many words as you can before the
+time runs out. There are several timer modes that determine how
+much time you start with, and if you get extra time when you find
+a word.
+
+You can join letters horizontally, vertically, or diagonally in any
+direction to make a word, so as long as the letters are next to
+each other on the board. However, you can not reuse the same letter
+cells in a single word. Also, each word must be at least three
+letters on a normal board, and four letters on a large board.
+
+WWW: http://gottcode.org/tanglet/
diff --git a/games/tanglet/pkg-plist b/games/tanglet/pkg-plist
new file mode 100644
index 000000000000..dd4d736c699c
--- /dev/null
+++ b/games/tanglet/pkg-plist
@@ -0,0 +1,33 @@
+bin/tanglet
+share/applications/tanglet.desktop
+share/icons/hicolor/128x128/apps/tanglet.png
+share/icons/hicolor/16x16/apps/tanglet.png
+share/icons/hicolor/22x22/apps/tanglet.png
+share/icons/hicolor/24x24/apps/tanglet.png
+share/icons/hicolor/256x256/apps/tanglet.png
+share/icons/hicolor/32x32/apps/tanglet.png
+share/icons/hicolor/48x48/apps/tanglet.png
+share/icons/hicolor/64x64/apps/tanglet.png
+share/icons/hicolor/scalable/apps/tanglet.svg
+share/pixmaps/tanglet_32.xpm
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/256x256/apps
+@dirrmtry share/icons/hicolor/256x256
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/24x24
+@dirrmtry share/icons/hicolor/22x22/apps
+@dirrmtry share/icons/hicolor/22x22
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications