aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-17 14:28:07 +0800
committerbapt <bapt@FreeBSD.org>2013-09-17 14:28:07 +0800
commitfde693e93db35fe3bd1a21756278115f8bfa5d96 (patch)
treea2818cc36d7e06c4c64a53b943d25f7b90c450f3 /games
parent12e20b0674c48f693a78fe456f8afcfb71b9685b (diff)
downloadfreebsd-ports-gnome-fde693e93db35fe3bd1a21756278115f8bfa5d96.tar.gz
freebsd-ports-gnome-fde693e93db35fe3bd1a21756278115f8bfa5d96.tar.zst
freebsd-ports-gnome-fde693e93db35fe3bd1a21756278115f8bfa5d96.zip
Convert to new perl framework
Convert from USE_GMAKE to USES=gmake
Diffstat (limited to 'games')
-rw-r--r--games/atr3d/Makefile4
-rw-r--r--games/blinkensisters/Makefile4
-rw-r--r--games/eboard/Makefile4
-rw-r--r--games/fairymax/Makefile4
-rw-r--r--games/freecell-solver/Makefile4
-rw-r--r--games/gracer/Makefile3
-rw-r--r--games/lmpc/Makefile4
-rw-r--r--games/stonesoup/Makefile5
-rw-r--r--games/wolfpack/Makefile4
-rw-r--r--games/xboard/Makefile3
10 files changed, 20 insertions, 19 deletions
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index 11faaedae2eb..5e79f49f766e 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -19,10 +19,10 @@ SDL_CONFIG?= ${LOCALBASE}/bin/sdl-config
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_GMAKE= yes
+USES= gmake perl5
USE_GL= glut glu
USE_XORG= xmu xi x11
-USE_PERL5_BUILD=yes
+USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
USE_AUTOTOOLS= automake autoconf
diff --git a/games/blinkensisters/Makefile b/games/blinkensisters/Makefile
index 1bde8a421f96..66d4e1c2de89 100644
--- a/games/blinkensisters/Makefile
+++ b/games/blinkensisters/Makefile
@@ -11,8 +11,8 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Parallax-style 2D scrolling platform game
USE_SDL= sdl image ttf
-USE_PERL5_BUILD= yes
-USES= cmake
+USE_PERL5= build
+USES= cmake perl5
CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
index 60d2d08f9639..eb8603be3f43 100644
--- a/games/eboard/Makefile
+++ b/games/eboard/Makefile
@@ -19,10 +19,10 @@ COMMENT= GTK+ chess board interface (mainly for FICS and chessd)
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
EXTRAS= 1pl2 2
-USES= shebangfix pkgconfig
+USES= shebangfix pkgconfig perl5
USE_BZIP2= yes
HAS_CONFIGURE= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
USE_GNOME= gtk20
SHEBANG_FILES= configure
diff --git a/games/fairymax/Makefile b/games/fairymax/Makefile
index f2500211de3b..0609727d0c47 100644
--- a/games/fairymax/Makefile
+++ b/games/fairymax/Makefile
@@ -29,8 +29,8 @@ MAN6= ${PORTNAME}.6
MLINKS= ${PORTNAME}.6 shamax.6 \
${PORTNAME}.6 maxqi.6
-USE_GMAKE= yes
-USE_PERL5_BUILD=yes
+USES= gmake perl5
+USE_PERL5= build
MAKE_ARGS+= INI_F=${DATADIR}/fmax.ini \
INI_Q=${DATADIR}/qmax.ini
diff --git a/games/freecell-solver/Makefile b/games/freecell-solver/Makefile
index 0cb18fc1dda0..aab0e5fa28d1 100644
--- a/games/freecell-solver/Makefile
+++ b/games/freecell-solver/Makefile
@@ -16,8 +16,8 @@ OPTIONS_DEFINE= TCMALLOC DOCS EXAMPLES
TCMALLOC_DESC= Use Google's TCMalloc
USE_BZIP2= yes
-USES= cmake:outsource
-USE_PERL5_BUILD= yes
+USES= cmake:outsource perl5
+USE_PERL5= build
CMAKE_ARGS= -DFCS_WITH_TEST_SUITE:BOOL=OFF
USE_LDCONFIG= yes
diff --git a/games/gracer/Makefile b/games/gracer/Makefile
index e0e190b8f8a7..a41340d51a57 100644
--- a/games/gracer/Makefile
+++ b/games/gracer/Makefile
@@ -17,7 +17,8 @@ LIB_DEPENDS= gif.5:${PORTSDIR}/graphics/giflib \
tcl84.1:${PORTSDIR}/lang/tcl84
USE_GL= glut
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
USE_AUTOTOOLS= autoconf213
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
CPPFLAGS="${CPPFLAGS}"
diff --git a/games/lmpc/Makefile b/games/lmpc/Makefile
index 71ee96468686..6c13d9ccb476 100644
--- a/games/lmpc/Makefile
+++ b/games/lmpc/Makefile
@@ -14,10 +14,10 @@ COMMENT= Tool to manipulate some FPS games demo recordings
LICENSE= GPLv2
-USES= gmake
+USES= gmake perl5
MAKE_JOBS_UNSAFE= yes
GNU_CONFIGURE= yes
-USE_PERL5_BUILD= yes
+USE_PERL5= build
PORTSCOUT= limit:.*[0-9]$$ # letter-suffixed files are binaries
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index 903025b19adf..ec770c970e6d 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -15,10 +15,9 @@ LICENSE_FILE= ${WRKDIR}/stone_soup-${PORTVERSION}/licence.txt
USE_SQLITE= yes
USE_XZ= yes
-USES= bison pkgconfig
-USE_GMAKE= yes
+USES= bison gmake perl5 pkgconfig
USE_LUA= 5.1
-USE_PERL5_BUILD= yes
+USE_PERL5= build
SAVEDIR= \~/.stonesoup
diff --git a/games/wolfpack/Makefile b/games/wolfpack/Makefile
index 48a51c310dcd..c270fa941da5 100644
--- a/games/wolfpack/Makefile
+++ b/games/wolfpack/Makefile
@@ -12,8 +12,8 @@ MAINTAINER= johans@FreeBSD.org
COMMENT= Long term multiplayer strategy game
MAKEFILE= GNUmakefile
-USE_GMAKE= yes
-USE_PERL5_BUILD= yes
+USES= gmake perl5
+USE_PERL5= build
GNU_CONFIGURE= yes
BINDIR= ${PREFIX}/lib/${PORTNAME}
VARDIR= ${PREFIX}/var/${PORTNAME}
diff --git a/games/xboard/Makefile b/games/xboard/Makefile
index e463d2565daa..c1e4997d4af8 100644
--- a/games/xboard/Makefile
+++ b/games/xboard/Makefile
@@ -29,7 +29,8 @@ CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAN6= xboard.6
INFO= xboard
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
INSTALLS_ICONS= yes
DATADIR= ${PREFIX}/share/games/${PORTNAME}