aboutsummaryrefslogtreecommitdiffstats
path: root/german/bugzilla
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2012-07-28 06:25:14 +0800
committerohauer <ohauer@FreeBSD.org>2012-07-28 06:25:14 +0800
commit57b81f5b0c5b9ac5d0fc5b31f3c9b1ae1e271c98 (patch)
tree2ccaaf47ef3b7daa4d8152ea7235a48ec22d62db /german/bugzilla
parent2c1b475aeba30e2efbdf5314b1c1b670e7d1a09a (diff)
downloadfreebsd-ports-gnome-57b81f5b0c5b9ac5d0fc5b31f3c9b1ae1e271c98.tar.gz
freebsd-ports-gnome-57b81f5b0c5b9ac5d0fc5b31f3c9b1ae1e271c98.tar.zst
freebsd-ports-gnome-57b81f5b0c5b9ac5d0fc5b31f3c9b1ae1e271c98.zip
- new port german/bugzilla42
- add patch to german/bugzilla so it reflects the security update - adjust version number in tempplates (3,6,10 / 4.0.7)
Diffstat (limited to 'german/bugzilla')
-rw-r--r--german/bugzilla/Makefile11
-rw-r--r--german/bugzilla/files/patch-de__default__global__confirm-user-match.html.tmpl24
2 files changed, 31 insertions, 4 deletions
diff --git a/german/bugzilla/Makefile b/german/bugzilla/Makefile
index 6a47341dc59a..149bf1481646 100644
--- a/german/bugzilla/Makefile
+++ b/german/bugzilla/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bugzilla
PORTVERSION= 4.0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= german
MASTER_SITES= SF
MASTER_SITE_SUBDIR=bugzilla-de/${PORTVERSION:R}/${PORTVERSION}
@@ -18,6 +18,8 @@ COMMENT= German localization for Bugzilla
RUN_DEPENDS= bugzilla>=${PORTVERSION}:${PORTSDIR}/devel/bugzilla
+LATEST_LINK= ${PKGNAMEPREFIX}bugzilla${PKGNAMESUFFIX}
+
NO_WRKSUBDIR= yes
.include "${.CURDIR}/../../devel/bugzilla/Makefile.common"
@@ -26,9 +28,10 @@ LANGDIR= ${WWWDIR}/template/de
# german template checks the bugzilla version number and displays
# non supported bugzilla version, however there are no relevant
-# changes in the templates between 4.0.5 and 4.0.6
+# changes in the templates between 4.0.5 and 4.0.7
post-patch:
- @${SED} -i '' -e 's|4.0.5|4.0.6|' ${WRKDIR}/de/default/global/gzversion.html.tmpl
+ @${SED} -i '' -e 's|4.0.5|4.0.7|' ${WRKDIR}/de/default/global/gzversion.html.tmpl
+ @${FIND} ${WRKDIR}/ -name \*.orig -delete
do-install:
@-${MKDIR} ${LANGDIR}
@@ -40,7 +43,7 @@ do-install:
.endif
# Maintainer
-plist: extract
+plist: patch
@( cd ${WRKDIR}/ && ${FIND} de -type f | ${AWK} '{print "%%WWWDIR%%/template/"$$1}' | ${SORT} > ${PLIST}.new )
@( cd ${WRKDIR}/ && ${FIND} de -type d | ${AWK} '{print "@dirrmtry %%WWWDIR%%/template/"$$1}' | ${SORT} -r >> ${PLIST}.new )
@if ${DIFF} -u ${PLIST} ${PLIST}.new ; then \
diff --git a/german/bugzilla/files/patch-de__default__global__confirm-user-match.html.tmpl b/german/bugzilla/files/patch-de__default__global__confirm-user-match.html.tmpl
new file mode 100644
index 000000000000..2d350c260e74
--- /dev/null
+++ b/german/bugzilla/files/patch-de__default__global__confirm-user-match.html.tmpl
@@ -0,0 +1,24 @@
+--- ./de/default/global/confirm-user-match.html.tmpl.orig 2012-07-27 21:42:53.000000000 +0200
++++ ./de/default/global/confirm-user-match.html.tmpl 2012-07-27 21:44:33.000000000 +0200
+@@ -159,8 +159,6 @@
+ [% ELSE %]
+ passte zu
+ <b>[% query.value.users.0.identity FILTER html %]</b>
+- <input type="hidden" name="[% field.key FILTER html %]"
+- value="[% query.value.users.0.login FILTER html %]">
+ [% END %]
+ [% ELSE %]
+ [% IF (query.key.length < 3) && !Param('emailsuffix') %]
+@@ -186,8 +184,10 @@
+
+ [% IF matchsuccess == 1 %]
+
+- [% SET exclude_these =
+- matches.keys.merge(['Bugzilla_login', 'Bugzilla_password']) %]
++ [% SET exclude_these = ['Bugzilla_login', 'Bugzilla_password'] %]
++ [% FOREACH key IN matches.keys %]
++ [% exclude_these.push(key) IF cgi.param(key) == '' %]
++ [% END %]
+ [% SET exclude = '^' _ exclude_these.join('|') _ '$' %]
+ [% PROCESS "global/hidden-fields.html.tmpl" exclude = exclude %]
+