aboutsummaryrefslogtreecommitdiffstats
path: root/german/hyphen/Makefile
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-07-29 21:13:17 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-07-29 21:13:17 +0800
commite7533864e7a7574c2d1b20a6b10f81c0561e4621 (patch)
tree709c0318625f1fe2eca8e12b791e969926c96e91 /german/hyphen/Makefile
parent3bc9ecccbd8279e4254d8eade21cc1a1837decfb (diff)
downloadfreebsd-ports-gnome-e7533864e7a7574c2d1b20a6b10f81c0561e4621.tar.gz
freebsd-ports-gnome-e7533864e7a7574c2d1b20a6b10f81c0561e4621.tar.zst
freebsd-ports-gnome-e7533864e7a7574c2d1b20a6b10f81c0561e4621.zip
- Move language prefix to PKGNAMEPREFIX
- Use DATADIR - Use PLIST_DIRSTRY for DATADIR - Explicitly list installing filenames - Bump PORTREVISION for PORTNAME and PLIST change - Sort PLIST - Cosmetic change
Diffstat (limited to 'german/hyphen/Makefile')
-rw-r--r--german/hyphen/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/german/hyphen/Makefile b/german/hyphen/Makefile
index 1ac1d9e5ec62..cbfe7e9cbd75 100644
--- a/german/hyphen/Makefile
+++ b/german/hyphen/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hyphen
PORTVERSION= 2007.02.17
+PORTREVISION= 1
CATEGORIES= german textproc
MASTER_SITES= http://ftp.osuosl.org/pub/openoffice/contrib/dictionaries/
DISTNAME= hyph_de_DE
@@ -19,20 +20,19 @@ LICENSE= LGPL21
USE_ZIP= yes
NO_BUILD= yes
-DEALIASES= de_AT de_BE de_CH de_LI de_LU
+PLIST_FILES= %%DATADIR%%/hyph_de_DE.dic
+PLIST_DIRSTRY= %%DATADIR%%
-PLIST_FILES= share/hyphen/hyph_de_DE.dic
+DEALIASES= de_AT de_BE de_CH de_LI de_LU
.for ALIAS in ${DEALIASES}
-PLIST_FILES+= share/hyphen/hyph_${ALIAS}.dic
+PLIST_FILES+= %%DATADIR%%/hyph_${ALIAS}.dic
.endfor
-PLIST_DIRS= share/hyphen
do-install:
- @${MKDIR} ${PREFIX}/share/hyphen
- @${INSTALL_DATA} ${WRKDIR}/hyph_de_DE.dic ${PREFIX}/share/hyphen
- @cd ${PREFIX}/share/hyphen; \
- for alias in ${DEALIASES}; do \
- ${LN} -s hyph_de_DE.dic hyph_$${alias}.dic ; \
- done
+ ${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${WRKDIR}/hyph_de_DE.dic ${DATADIR}/
+.for ALIAS in ${DEALIASES}
+ ${LN} -s hyph_de_DE.dic ${DATADIR}/hyph_${ALIAS}.dic
+.endfor
.include <bsd.port.mk>