aboutsummaryrefslogtreecommitdiffstats
path: root/german
diff options
context:
space:
mode:
authorsheldonh <sheldonh@FreeBSD.org>2000-09-07 22:22:48 +0800
committersheldonh <sheldonh@FreeBSD.org>2000-09-07 22:22:48 +0800
commit4ea073e1c6c57446d3193f6385a0d5ce1cc3e63f (patch)
tree7547a61f0be60db2b3a9802446dacdff4d4897a4 /german
parent7048da3e0a16a9fb3fa439e096f9a7629fd0d957 (diff)
downloadfreebsd-ports-gnome-4ea073e1c6c57446d3193f6385a0d5ce1cc3e63f.tar.gz
freebsd-ports-gnome-4ea073e1c6c57446d3193f6385a0d5ce1cc3e63f.tar.zst
freebsd-ports-gnome-4ea073e1c6c57446d3193f6385a0d5ce1cc3e63f.zip
Fix the error detection routines at the end.
Remove some unused cruft. Get LD_LIBRARY_PATH recognized properly. PREFIX-clean. Submitted by: maintainer
Diffstat (limited to 'german')
-rw-r--r--german/staroffice52/Makefile25
-rw-r--r--german/staroffice70/Makefile33
2 files changed, 32 insertions, 26 deletions
diff --git a/german/staroffice52/Makefile b/german/staroffice52/Makefile
index c185b5d62ee2..6a62c7ceec5b 100644
--- a/german/staroffice52/Makefile
+++ b/german/staroffice52/Makefile
@@ -30,7 +30,7 @@ NO_BUILD= yes
DIST_SUBDIR= staroffice52
WRKSRC= ${WRKDIR}/office52
TMPDIR= ${WRKDIR}/tmp
-ADEBAS= soa-5_2-ga-bin-linux-de.bin
+LD_PATH= ${TMPDIR}:${WRKSRC}:/compat/linux/lib:/compat/linux/usr/lib
.include <bsd.port.pre.mk>
@@ -91,16 +91,23 @@ do-install:
@ ${ECHO}
@ ${FALSE}
.else
-.if exists(/compat/linux/usr/local)
- @${LN} -fs /compat/linux/usr/local/office52 ${PREFIX}/office52
+if exists(/compat/linux/${PREFIX})
+ @${LN} -fs /compat/linux/${PREFIX}/office52 ${PREFIX}/office52
.endif
@${CAT} ${PKGDIR}/MESSAGE
- @-SAL_IGNOREXERRORS=1 TEMP=${TMPDIR} /compat/linux/bin/sh -c '${WRKSRC}/setup /net'
- @ ${ECHO}
- @ ${ECHO} Ignorieren Sie die Fehlermeldung. StarOffice5.2 wurde erfolgreich
- @ ${ECHO} auf Ihrem System installiert.
- @ ${ECHO}
-.endif
+ @-SAL_IGNOREXERRORS=1 TEMP=${TMPDIR} LD_LIBRARY_PATH=${LD_PATH} /compat/linux/bin/sh -c '${WRKSRC}/setup /net'
+ @if [ -f ${PREFIX}/office52/program/setup ]; then \
+ ${ECHO} ; \
+ ${ECHO} Ignorieren Sie die Fehlermeldung. StarOffice5.2 wurde erfolgreich ; \
+ ${ECHO} auf Ihrem System installiert. ; \
+ ${ECHO} ; \
+ .else \
+ ${ECHO} ; \
+ ${ECHO} Während Ihrer StarOffice5.2 Installation ist ein Fehler aufgetreten. ; \
+ ${ECHO} Bitte schicken Sie ein Mail mit dem Fehlerbeschrieb an mb@imp.ch. Danke ; \
+ ${ECHO} ; \
+ ${FALSE} ; \
+ .endif
post-install:
@${PATCH} -s ${PREFIX}/office52/program/setup ${FILESDIR}/setup.patch
diff --git a/german/staroffice70/Makefile b/german/staroffice70/Makefile
index ff4ca8cc1b08..58ad83f539fa 100644
--- a/german/staroffice70/Makefile
+++ b/german/staroffice70/Makefile
@@ -35,7 +35,7 @@ NO_BUILD= yes
DIST_SUBDIR= staroffice52
WRKSRC= ${WRKDIR}/office52
TMPDIR= ${WRKDIR}/tmp
-ADEBAS= soa-5_2-ga-bin-linux-en.bin
+LD_PATH= ${TMPDIR}:${WRKSRC}:/compat/linux/lib:/compat/linux/usr/lib
.include <bsd.port.pre.mk>
@@ -96,24 +96,23 @@ do-install:
@ ${ECHO}
@ ${FALSE}
.else
-.if exists(/compat/linux/usr/local)
- @${LN} -fs /compat/linux/usr/local/office52 ${PREFIX}/office52
+.if exists(/compat/linux/${PREFIX})
+ @${LN} -fs /compat/linux/${PREFIX}/office52 ${PREFIX}/office52
.endif
@${CAT} ${PKGDIR}/MESSAGE
- @LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${TMPDIR}:${WRKSRC}:/compat/linux/lib:/compat/linux/usr/lib
- @-SAL_IGNOREXERRORS=1 TEMP=${TMPDIR} /compat/linux/bin/sh -c '${WRKSRC}/setup /net'
-.if exists(/usr/local/office52/program/setup)
- @ ${ECHO}
- @ ${ECHO} Ignore the error-message. StarOffice5.2 has been installed
- @ ${ECHO} successfully on your system.
- @ ${ECHO}
-.else
- @ ${ECHO}
- @ ${ECHO} An error occured during StarOffice5.2 install. Please send a mail with debug-output and
- @ ${ECHO} some information about your FreeBSD-environment to mb@imp.ch. Thanks.
- @ ${ECHO}
- @ ${FALSE}
-.endif
+ @-SAL_IGNOREXERRORS=1 TEMP=${TMPDIR} LD_LIBRARY_PATH=${LD_PATH} /compat/linux/bin/sh -c '${WRKSRC}/setup /net'
+ @if [ -f ${PREFIX}/office52/program/setup ]; then \
+ ${ECHO} ; \
+ ${ECHO} Ignore the error-message. StarOffice5.2 has been installed ; \
+ ${ECHO} successfully on your system. ; \
+ ${ECHO} ; \
+ else \
+ ${ECHO} ; \
+ ${ECHO} An error occured during StarOffice5.2 install. Please send a mail with debug-output and ; \
+ ${ECHO} some information about your FreeBSD-environment to mb@imp.ch. Thanks. ; \
+ ${ECHO} ; \
+ ${FALSE} ; \
+ fi
.endif
post-install: