aboutsummaryrefslogtreecommitdiffstats
path: root/german
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-06-06 00:27:47 +0800
committermiwi <miwi@FreeBSD.org>2006-06-06 00:27:47 +0800
commit8ae6e09ecf25280b56731505db9c75cfb71ee801 (patch)
tree68918e83361385e9a78569a29f47f62ee458f495 /german
parent7f075ac48df310bfc7c8f8d9d1195880e0697c13 (diff)
downloadfreebsd-ports-gnome-8ae6e09ecf25280b56731505db9c75cfb71ee801.tar.gz
freebsd-ports-gnome-8ae6e09ecf25280b56731505db9c75cfb71ee801.tar.zst
freebsd-ports-gnome-8ae6e09ecf25280b56731505db9c75cfb71ee801.zip
German-localized version of wordpress.
WordPress is a state-of-the-art semantic personal publishing platform with a focus on aesthetics, web standards, and usability. More simply, Wordpress is what you use when you want to work with your blogging software, not fight it. PR: ports/98448 Submitted by: miwi Approved by: krion (mentor)
Diffstat (limited to 'german')
-rw-r--r--german/Makefile1
-rw-r--r--german/wordpress/Makefile61
-rw-r--r--german/wordpress/distinfo3
-rw-r--r--german/wordpress/pkg-descr7
-rw-r--r--german/wordpress/pkg-message6
5 files changed, 78 insertions, 0 deletions
diff --git a/german/Makefile b/german/Makefile
index 2d210b09f689..b0806839dfbc 100644
--- a/german/Makefile
+++ b/german/Makefile
@@ -34,5 +34,6 @@
SUBDIR += tvbrowser
SUBDIR += unix-connect
SUBDIR += webalizer2
+ SUBDIR += wordpress
.include <bsd.port.subdir.mk>
diff --git a/german/wordpress/Makefile b/german/wordpress/Makefile
new file mode 100644
index 000000000000..a93ead031f7f
--- /dev/null
+++ b/german/wordpress/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: wordpress
+# Date created: 2006-06-03
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+# (based on wordpress by Elvis Chiang)
+#
+# $FreeBSD$
+#
+
+PORTNAME= wordpress
+PORTVERSION= 2.0.3
+CATEGORIES= german www
+MASTER_SITES= http://files.wordpress.de/uploads/
+DISTNAME= wp_de_20
+PKGNAMEPREFIX= de-
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A state-of-the-art semantic personal publishing platform
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_ZIP= YES
+USE_PHP= mysql pcre xml
+NO_BUILD= YES
+WANT_PHP_WEB= YES
+WORDPRESS?= www/wordpress
+PLIST_SUB+= WORDPRESS=${WORDPRESS}
+PLIST= ${WRKDIR}/pkg-plist
+
+PORTDOCS= license.txt readme.html liesmich.html
+
+pre-everything::
+ @${ECHO_CMD} "If you want to upgrade, you must read upgrade document."
+ @${ECHO_CMD} ""
+ @sleep 1
+
+pre-install:
+ cd ${WRKSRC} && ${FIND} -s * -type f | \
+ ${SED} -e 's|^|${WORDPRESS}/|' > ${PLIST} \
+ && ${FIND} -d * -type d | \
+ ${SED} -e 's|^|@dirrm ${WORDPRESS}/|' >> ${PLIST} \
+ && ${ECHO_CMD} @dirrm ${WORDPRESS} >> ${PLIST} \
+ && ${ECHO_CMD} @dirrmtry www/data >> ${PLIST}
+ if [! -f ${WRKSRC}/wp-config-sample.php]; then ${CP} \
+ ${WRKSRC}/wp-config.php.sample ${WRKSRC}/wp-config.php; fi
+
+do-install:
+ -@${MKDIR} ${PREFIX}/${WORDPRESS}
+ @${CHOWN} ${WWWOWN}:${WWWGRP} ${PREFIX}/${WORDPRESS}
+ @${CHMOD} 755 ${PREFIX}/${WORDPRESS}
+ ${CP} -R ${WRKSRC}/ ${PREFIX}/${WORDPRESS}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/${i}
+.endfor
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/german/wordpress/distinfo b/german/wordpress/distinfo
new file mode 100644
index 000000000000..f3e8d055f788
--- /dev/null
+++ b/german/wordpress/distinfo
@@ -0,0 +1,3 @@
+MD5 (wp_de_20.zip) = 527e501726f00b6566814b013d518422
+SHA256 (wp_de_20.zip) = a460375fa9f52e7482c962d50b80d67a22052c84ba37cbcc07f28395fbdde5f9
+SIZE (wp_de_20.zip) = 726904
diff --git a/german/wordpress/pkg-descr b/german/wordpress/pkg-descr
new file mode 100644
index 000000000000..cb299ed118e6
--- /dev/null
+++ b/german/wordpress/pkg-descr
@@ -0,0 +1,7 @@
+WordPress is a state-of-the-art semantic personal publishing platform
+with a focus on aesthetics, web standards, and usability.
+
+More simply, Wordpress is what you use when you want to work
+with your blogging software, not fight it.
+
+WWW: http://wordpress.de/
diff --git a/german/wordpress/pkg-message b/german/wordpress/pkg-message
new file mode 100644
index 000000000000..b34f38bb3896
--- /dev/null
+++ b/german/wordpress/pkg-message
@@ -0,0 +1,6 @@
+
+ **** NOTE ****
+ Before the first use of WordPress, copy wp-config-sample.php to wp-config.php
+ in ${PREFIX}/${WORDPRESS}
+ And Modify it to fit your MySQL.
+ Maybe you need 'mysqladmin create wordpress' first