aboutsummaryrefslogtreecommitdiffstats
path: root/german
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
committermat <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
commit9e7703aff1c96dce4c11180df6bfd80c536b777a (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /german
parentfbcb74cea8547a229eabdb6530aecdeb2689cf82 (diff)
downloadfreebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.tar.gz
freebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.tar.zst
freebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'german')
-rw-r--r--german/BBBike/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/german/BBBike/Makefile b/german/BBBike/Makefile
index e17637af196b..0e1aa6b6ff38 100644
--- a/german/BBBike/Makefile
+++ b/german/BBBike/Makefile
@@ -66,8 +66,8 @@ post-patch:
@${RM} ${WRKSRC}/tmp/.keep_me
do-build:
- cd ${WRKSRC}/ext && ${MAKE} PERL=${PERL5} all install
- cd ${WRKSRC}/ext && ${MAKE} PERL=${PERL5} clean
+ cd ${WRKSRC}/ext && ${MAKE} PERL=${PERL} all install
+ cd ${WRKSRC}/ext && ${MAKE} PERL=${PERL} clean
${FIND} ${WRKSRC}/lib -name "*.so" | ${XARGS} ${CHMOD} u+w
${FIND} ${WRKSRC}/lib -name "*.so" | ${XARGS} ${STRIP_CMD}
${FIND} ${WRKSRC}/lib -name "*.so" | ${XARGS} ${CHMOD} u-w