aboutsummaryrefslogtreecommitdiffstats
path: root/german
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-08-12 05:23:18 +0800
committermarino <marino@FreeBSD.org>2014-08-12 05:23:18 +0800
commitd52c32cd6262f0941994d04dd60239592f844fc6 (patch)
tree6c6f61777e8d237f15ba87b1f348ab50e54439ce /german
parent0d1776cb48d9fcc16466632ee8759ff9e12b7f6b (diff)
downloadfreebsd-ports-gnome-d52c32cd6262f0941994d04dd60239592f844fc6.tar.gz
freebsd-ports-gnome-d52c32cd6262f0941994d04dd60239592f844fc6.tar.zst
freebsd-ports-gnome-d52c32cd6262f0941994d04dd60239592f844fc6.zip
german/BBBike: Clear up build warnings caused by early shell command
PR: 190667 Reported by: Sean Bruno Submitted by: eserte12 (yahoo.de) Approved by: Just Fix It
Diffstat (limited to 'german')
-rw-r--r--german/BBBike/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/german/BBBike/Makefile b/german/BBBike/Makefile
index dbe0bd8faa94..135848c7fb1d 100644
--- a/german/BBBike/Makefile
+++ b/german/BBBike/Makefile
@@ -13,7 +13,7 @@ COMMENT= Route-finder for cyclists in Berlin and Brandenburg
BUILD_DEPENDS= p5-Inline>=0:${PORTSDIR}/devel/p5-Inline \
p5-CDB_File>=0:${PORTSDIR}/databases/p5-CDB_File
RUN_DEPENDS= p5-Tk>=0:${PORTSDIR}/x11-toolkits/p5-Tk \
-p5-Inline>=0:${PORTSDIR}/devel/p5-Inline \
+ p5-Inline>=0:${PORTSDIR}/devel/p5-Inline \
p5-CDB_File>=0:${PORTSDIR}/databases/p5-CDB_File
USES= perl5
@@ -23,7 +23,14 @@ MYDESTDIR= ${STAGEDIR}${PREFIX}/BBBike
.include <bsd.port.pre.mk>
+# The following != assignment will generate a warning
+# with portlint et al. Problem is that the nearest
+# replacements ${PERL_VER}/${PERL_ARCH} do not work here:
+# the value of PERL_ARCH is always "mach" on FreeBSD systems,
+# but $Config{archname} here is something like "amd64-freebsd"
+.if exists(${PERL5})
LOCAL_PERL_ARCH!= ${PERL5} -MConfig -e '$$x = qq{$$Config{version}/$$Config{archname}}; $$x =~ s{/}{\\\\/}g; print $$x'
+.endif
PLIST_SUB= LOCAL_PERL_ARCH=${LOCAL_PERL_ARCH}
BBBIKE_PERL_EXE= bbbike cbbbike bbbikeclient cmdbbbike smsbbbike