aboutsummaryrefslogtreecommitdiffstats
path: root/german
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-10-06 16:35:32 +0800
committertobik <tobik@FreeBSD.org>2018-10-06 16:35:32 +0800
commitadee7060f95576d28a0b092ccaa6f5bfcb7961bf (patch)
tree2a0bd36f619c83c4bb77235ad543ae1027313066 /german
parent8a841585ded539ef5a340a44b2d413e75689df47 (diff)
downloadfreebsd-ports-gnome-adee7060f95576d28a0b092ccaa6f5bfcb7961bf.tar.gz
freebsd-ports-gnome-adee7060f95576d28a0b092ccaa6f5bfcb7961bf.tar.zst
freebsd-ports-gnome-adee7060f95576d28a0b092ccaa6f5bfcb7961bf.zip
german/tipp10: Fix runtime, cleanup dependencies
- Drop unnecessary sqlite2 plugin run, and unused qtestlib and script dependencies - Make sure DATADIR is actually passed through to the build. Currently qmake passes it as "" to the compiler which leads to tipp10 not finding its data files on first startup.
Diffstat (limited to 'german')
-rw-r--r--german/tipp10/Makefile18
-rw-r--r--german/tipp10/files/patch-tipp10.pro8
2 files changed, 8 insertions, 18 deletions
diff --git a/german/tipp10/Makefile b/german/tipp10/Makefile
index 63ec717bca35..0988e0c7fff2 100644
--- a/german/tipp10/Makefile
+++ b/german/tipp10/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= tipp10
-PORTVERSION= 2.1.0
-PORTREVISION= 2
+DISTVERSION= 2-1-0
+PORTREVISION= 3
CATEGORIES= german
MASTER_SITES= http://www.tipp10.com/en/download/
-DISTNAME= tipp10_source_v2-1-0
+DISTNAME= tipp10_source_v${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= 10-finger touch typing learning program
@@ -16,15 +16,13 @@ LICENSE_FILE= ${WRKSRC}/license_en.txt
USES= qmake dos2unix qt:4 zip
DOS2UNIX_GLOB= *.pro *.cpp
-USE_QT= gui sql corelib network script qtestlib \
- rcc_build uic_build moc_build \
- sql-sqlite2_run sql-sqlite3_run
-QMAKE_ARGS+= DATADIR="${DATADIR}"
-WRKSRC= ${WRKDIR}/tipp10_source_v2-1-0
+USE_QT= corelib gui network sql rcc_build uic_build moc_build \
+ sql-sqlite3_run
pre-configure:
- @cd ${WRKSRC} \
- && for i in `grep -lR 'QCoreApplication::applicationDirPath()' *`; do ${REINPLACE_CMD} -e 's/QCoreApplication::applicationDirPath()/QString(DATADIR)/g' $$i ; done
+ cd ${WRKSRC} \
+ && for i in `grep -lR 'QCoreApplication::applicationDirPath()' *`; do \
+ ${REINPLACE_CMD} -e 's,QCoreApplication::applicationDirPath(),QString("${DATADIR}"),g' $$i ; done
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tipp10 ${STAGEDIR}${PREFIX}/bin
diff --git a/german/tipp10/files/patch-tipp10.pro b/german/tipp10/files/patch-tipp10.pro
deleted file mode 100644
index 05e362377731..000000000000
--- a/german/tipp10/files/patch-tipp10.pro
+++ /dev/null
@@ -1,8 +0,0 @@
---- tipp10.pro 2011-03-12 20:22:32.000000000 +0100
-+++ tipp10.pro 2011-07-24 14:24:03.000000000 +0200
-@@ -88,3 +88,5 @@
- sql/startsql.cpp \
- games/abcrainwidget.cpp \
- games/charball.cpp
-+
-+DEFINES += "DATADIR=\"\\\"$$(DATADIR)\\\"\""