aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ImageMagick
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /graphics/ImageMagick
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'graphics/ImageMagick')
-rw-r--r--graphics/ImageMagick/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 1d59563d5d99..7f9246044354 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -251,9 +251,9 @@ CONFIGURE_ARGS+= --without-freetype
.if !defined(WITHOUT_IMAGEMAGICK_FONTCONFIG)
LIB_DEPENDS+= fontconfig:${PORTSDIR}/x11-fonts/fontconfig
CONFIGURE_ARGS+= --with-fontconfig
-CONFIGURE_ENV+= FONTCONFIG_CFLAGS="-I${X11BASE}/include" \
- FONTCONFIG_LIBS="-L${X11BASE}/lib"
-MAKE_ENV+= FONTCONFIG_CFLAGS="-I${X11BASE}/include"
+CONFIGURE_ENV+= FONTCONFIG_CFLAGS="-I${LOCALBASE}/include" \
+ FONTCONFIG_LIBS="-L${LOCALBASE}/lib"
+MAKE_ENV+= FONTCONFIG_CFLAGS="-I${LOCALBASE}/include"
.else
CONFIGURE_ARGS+= --without-fontconfig
.endif
@@ -284,8 +284,8 @@ IGNORE= SVG support requires X11 libraries, please unset WITHOUT_X11
.endif
LIB_DEPENDS+= rsvg-2:${PORTSDIR}/graphics/librsvg2
CONFIGURE_ARGS+= --with-rsvg
-CONFIGURE_ENV+= RSVG_CFLAGS="-I${X11BASE}/include/librsvg-2" \
- RSVG_LIBS="-L${X11BASE}/lib"
+CONFIGURE_ENV+= RSVG_CFLAGS="-I${LOCALBASE}/include/librsvg-2" \
+ RSVG_LIBS="-L${LOCALBASE}/lib"
.else
CONFIGURE_ARGS+= --without-rsvg
.endif