aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/Mesa3
diff options
context:
space:
mode:
authorhsu <hsu@FreeBSD.org>1995-02-08 05:58:10 +0800
committerhsu <hsu@FreeBSD.org>1995-02-08 05:58:10 +0800
commit11a78be24462c3301b171fe796fbd2b88147437a (patch)
tree0b3b116f3e4ca6b546ed0bbb2e5355edce090100 /graphics/Mesa3
parent1faff2fcf5924d4bf409ffd088098907f6ab851f (diff)
downloadfreebsd-ports-gnome-11a78be24462c3301b171fe796fbd2b88147437a.tar.gz
freebsd-ports-gnome-11a78be24462c3301b171fe796fbd2b88147437a.tar.zst
freebsd-ports-gnome-11a78be24462c3301b171fe796fbd2b88147437a.zip
Mesa - a 3-D graphics library similiar to OpenGL
Diffstat (limited to 'graphics/Mesa3')
-rw-r--r--graphics/Mesa3/Makefile23
-rw-r--r--graphics/Mesa3/distinfo1
-rw-r--r--graphics/Mesa3/files/patch-aa16
3 files changed, 40 insertions, 0 deletions
diff --git a/graphics/Mesa3/Makefile b/graphics/Mesa3/Makefile
new file mode 100644
index 000000000000..2eb6ad0c9f47
--- /dev/null
+++ b/graphics/Mesa3/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: Mesa
+# Version required: 1.0beta
+# Date created: Tue Feb 7 12:02:49 1995
+# Whom: hsu
+#
+# $Id$
+#
+
+DISTNAME= Mesa-1.0beta
+EXTRACT_SUFX= .tar.Z
+MASTER_SITES= ftp://iris.ssec.wisc.edu/pub/misc/
+WRKSRC= ${WRKDIR}/Mesa
+ALL_TARGET= freebsd
+# won't install until I convert the Makefiles to Imakefiles
+NO_INSTALL= yes
+
+# won't need this after I convert the Makefiles to Imakefiles
+pre-build:
+ if [ ! -e /usr/include/X11 ]; then \
+ ln -s /usr/X11R6/include/X11 /usr/include; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/graphics/Mesa3/distinfo b/graphics/Mesa3/distinfo
new file mode 100644
index 000000000000..5b08c4f99303
--- /dev/null
+++ b/graphics/Mesa3/distinfo
@@ -0,0 +1 @@
+MD5 (Mesa-1.0beta.tar.Z) = 4b4ecf8c1cdd2556e9d059b9c6f883bb
diff --git a/graphics/Mesa3/files/patch-aa b/graphics/Mesa3/files/patch-aa
new file mode 100644
index 000000000000..1b4d82812778
--- /dev/null
+++ b/graphics/Mesa3/files/patch-aa
@@ -0,0 +1,16 @@
+*** samples/speed.c.0 Fri Jan 27 18:41:09 1995
+--- samples/speed.c Sun Feb 5 15:43:42 1995
+***************
+*** 122,128 ****
+--- 122,132 ----
+ clock_t clk;
+
+ clk = times(&tm);
++ #ifdef __FreeBSD__
++ return (double) clk / (double) sysconf(_SC_CLK_TCK);
++ #else
+ return (double)clk / (double)HZ;
++ #endif
+ #else
+ return 0;
+ #endif