aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/aalib
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-04-17 08:18:05 +0800
committerreg <reg@FreeBSD.org>2000-04-17 08:18:05 +0800
commit8b766534122d71052c9f8e5a0752944edf0450f8 (patch)
tree255862bd3b0c32802317a9ddc3193fd714753916 /graphics/aalib
parente0c8ef49d897de0719277097a1e6578f291f493e (diff)
downloadfreebsd-ports-gnome-8b766534122d71052c9f8e5a0752944edf0450f8.tar.gz
freebsd-ports-gnome-8b766534122d71052c9f8e5a0752944edf0450f8.tar.zst
freebsd-ports-gnome-8b766534122d71052c9f8e5a0752944edf0450f8.zip
Standardize all user defined options to the booleans WITH_FOO and
WITHOUT_FOO. Begin the process of reserving these prefixes for user defined options. No comment by: ports
Diffstat (limited to 'graphics/aalib')
-rw-r--r--graphics/aalib/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/graphics/aalib/Makefile b/graphics/aalib/Makefile
index 1b82b377b7ca..41c6bd9a38c8 100644
--- a/graphics/aalib/Makefile
+++ b/graphics/aalib/Makefile
@@ -15,14 +15,14 @@ MAINTAINER= ports@FreeBSD.org
USE_AUTOCONF= yes
USE_LIBTOOL= yes
+.include <bsd.port.pre.mk>
+
#
# Support for X11 is compiled in by default only if X11 is installed.
#
-.if !exists(${X11BASE})
-NO_X11?= yes
-.endif
-.if !defined(NO_X11)
-USE_XLIB=YES
+.if defined(WITH_X11) || (exists(${X11BASE}/lib/libX11.a) \
+ && !defined(WITHOUT_X11))
+USE_XLIB= yes
CONFIGURE_ARGS= --with-x --x-includes="${X11BASE}/include" \
--x-libraries="${X11BASE}/lib"
.else
@@ -32,7 +32,4 @@ CONFIGURE_ARGS= --with-x11-driver=no
post-patch:
@${PERL} -pi -e "s:/usr/local:${LOCALBASE}:g;" ${WRKSRC}/configure.in
-post-install:
- @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>