aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ale
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-13 05:42:32 +0800
committerbapt <bapt@FreeBSD.org>2012-06-13 05:42:32 +0800
commitf5eba1acd02cb57a7650fe6c33b912240f6ab8ab (patch)
tree785d921da1883d2c1df77c5add82a844e2ae090b /graphics/ale
parenteb2a7f0a6ba691b8505dc2684f14abff26a76009 (diff)
downloadfreebsd-ports-gnome-f5eba1acd02cb57a7650fe6c33b912240f6ab8ab.tar.gz
freebsd-ports-gnome-f5eba1acd02cb57a7650fe6c33b912240f6ab8ab.tar.zst
freebsd-ports-gnome-f5eba1acd02cb57a7650fe6c33b912240f6ab8ab.zip
Conver to new options framework
Diffstat (limited to 'graphics/ale')
-rw-r--r--graphics/ale/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/graphics/ale/Makefile b/graphics/ale/Makefile
index 1de19cbc2e99..719541b88c79 100644
--- a/graphics/ale/Makefile
+++ b/graphics/ale/Makefile
@@ -15,9 +15,9 @@ MASTER_SITES= http://auricle.dyndns.org/ALE/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Anti-Lamenessing Engine
-OPTIONS= DOUBLE "64bit Data Precision Support" off \
- FFTW3 "FFTW3 Support" on \
- IMAGEMAGICK "ImageMagick Support" on
+OPTIONS_DEFINE= DOUBLE FFTW3 MAGICK
+OPTIONS_DEFAULT= FFTW3 MAGICK
+DOUBLE_DESC= 64bit Data Precision Support
USE_GNOME= gnomehack
GNU_CONFIGURE= yes
@@ -38,20 +38,20 @@ PORTSCOUT= limitw:1,even
BROKEN= Does not build on alpha
.endif
-.if defined(WITH_DOUBLE)
+.if ${PORT_OPTIONS:MDOUBLE}
CONFIGURE_ARGS+= --with-colors=double --with-coords=double
.endif
-.if defined(WITHOUT_FFTW3)
-CONFIGURE_ARGS+= --without-fftw3
-.else
+.if ${PORT_OPTIONS:MFFTW3}
LIB_DEPENDS+= fftw3:${PORTSDIR}/math/fftw3
+.else
+CONFIGURE_ARGS+= --without-fftw3
.endif
-.if defined(WITHOUT_IMAGEMAGICK)
-CONFIGURE_ARGS+= --without-imagemagick
-.else
+.if ${PORT_OPTIONS:MMAGICK}
LIB_DEPENDS+= MagickWand.5:${PORTSDIR}/graphics/ImageMagick
+.else
+CONFIGURE_ARGS+= --without-imagemagick
.endif
.include <bsd.port.post.mk>