aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/argyllcms
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-08-09 20:55:19 +0800
committerkwm <kwm@FreeBSD.org>2015-08-09 20:55:19 +0800
commit0ec7687e79d2c6d7ff462c6ec3c241e10f8fd807 (patch)
tree4a03482ca5bc32d6dd99cfcc8c7e6c3c7935efe1 /graphics/argyllcms
parent0ff64d56155854613a77dd9fb39214e44bdd255f (diff)
downloadfreebsd-ports-gnome-0ec7687e79d2c6d7ff462c6ec3c241e10f8fd807.tar.gz
freebsd-ports-gnome-0ec7687e79d2c6d7ff462c6ec3c241e10f8fd807.tar.zst
freebsd-ports-gnome-0ec7687e79d2c6d7ff462c6ec3c241e10f8fd807.zip
* Set USES=compiler:c11 to select clang on 9.3-R. Pass MAKE_ENV to jam in
the do-build target so CC & friends get set in the enviroment so jam can pick them up. This fixes the build on 9.3-R amd64. [1] * Add patch from debian to fix segfault in dispwin with bad command line options Submitted by: pkg-fallout [1]
Diffstat (limited to 'graphics/argyllcms')
-rw-r--r--graphics/argyllcms/Makefile5
-rw-r--r--graphics/argyllcms/files/patch-spectro_dispwin.c17
2 files changed, 20 insertions, 2 deletions
diff --git a/graphics/argyllcms/Makefile b/graphics/argyllcms/Makefile
index 390061f064f2..76929ed300b2 100644
--- a/graphics/argyllcms/Makefile
+++ b/graphics/argyllcms/Makefile
@@ -3,6 +3,7 @@
PORTNAME= argyllcms
PORTVERSION= 1.7.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.argyllcms.com/
DISTNAME= Argyll_V${PORTVERSION}_src
@@ -17,14 +18,14 @@ LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff
WRKSRC= ${WRKDIR}/Argyll_V${PORTVERSION}
-USES= cpe jpeg zip
+USES= compiler:c11 cpe jpeg zip
USE_XORG= x11 xau xdmcp xext xinerama xrandr xscrnsaver xxf86vm
post-patch:
@${REINPLACE_CMD} 's:711:755:g' ${WRKSRC}/Jambase
do-build:
- @cd ${WRKSRC} && jam -q -fJambase -j${MAKE_JOBS_NUMBER}
+ @cd ${WRKSRC} && ${MAKE_ENV} jam -q -fJambase -j${MAKE_JOBS_NUMBER}
do-install:
@cd ${WRKSRC} && ${SETENV} DESTDIR=${STAGEDIR} PREFIX=${PREFIX} \
diff --git a/graphics/argyllcms/files/patch-spectro_dispwin.c b/graphics/argyllcms/files/patch-spectro_dispwin.c
new file mode 100644
index 000000000000..379b3fd96e70
--- /dev/null
+++ b/graphics/argyllcms/files/patch-spectro_dispwin.c
@@ -0,0 +1,17 @@
+Description: Add check for NULL pointer
+Author: Jörg Frings-Fürst <debian@jff-webhsoting.net>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=700253
+Forwarded: http://www.freelists.org/post/argyllcms/dispwin-bad-command-line-option-makes-dispwin-segfault
+Reviewed-by:
+Last-Update: 2014-09-14
+---
+--- spectro/dispwin.c.orig 2015-05-01 10:15:55.000000000 +0200
++++ spectro/dispwin.c 2015-08-09 14:48:49.778919000 +0200
+@@ -5547,6 +5547,7 @@
+
+ /* Display number */
+ else if (argv[fa][1] == 'd') {
++ if(na == NULL) usage(0,"-d parameter missing");
+ if (strncmp(na,"web",3) == 0
+ || strncmp(na,"WEB",3) == 0) {
+ webdisp = 8080;