aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/bmp2html
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2019-02-06 18:26:57 +0800
committerehaupt <ehaupt@FreeBSD.org>2019-02-06 18:26:57 +0800
commit75da9e7b591efa4e267f9c4485a0cceccb6b17c2 (patch)
treece28611d4109463dbcb4ec6ef5717bef563fafcf /graphics/bmp2html
parent5777986c83ed1efb10232b7c00b03910a755dc75 (diff)
downloadfreebsd-ports-gnome-75da9e7b591efa4e267f9c4485a0cceccb6b17c2.tar.gz
freebsd-ports-gnome-75da9e7b591efa4e267f9c4485a0cceccb6b17c2.tar.zst
freebsd-ports-gnome-75da9e7b591efa4e267f9c4485a0cceccb6b17c2.zip
- Add LICENSE
- Take compile/link flags from sdl_config, instead of hardcoding them, simplify the port - Remove bundled binary earlier, in post-extract PR: 235525 Submitted by: amdmi3
Diffstat (limited to 'graphics/bmp2html')
-rw-r--r--graphics/bmp2html/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/graphics/bmp2html/Makefile b/graphics/bmp2html/Makefile
index b70ed1c755bb..bd43fbbb6df6 100644
--- a/graphics/bmp2html/Makefile
+++ b/graphics/bmp2html/Makefile
@@ -11,22 +11,19 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= BMP to HTML converter
-USE_SDL= sdl
+LICENSE= PD
-LDFLAGS+= -L${LOCALBASE}/lib
-SDL_FLAGS= -I${LOCALBASE}/include/SDL -I${LOCALBASE}/include
-EXTRA_LDFLAGS= -lSDL -pthread
-DEFINES= -D_REENTRANT
+USE_SDL= sdl
PLIST_FILES= bin/bmp2html
-post-patch:
+post-extract:
@${RM} ${WRKSRC}/${PORTNAME}
do-build:
- ${CC} ${CFLAGS} ${LDFLAGS} ${SDL_FLAGS} ${DEFINES} -c \
+ ${CC} ${CFLAGS} `${SDL_CONFIG} --cflags` -c \
-o ${WRKSRC}/${PORTNAME}.o ${WRKSRC}/${PORTNAME}.c
- ${CC} ${CFLAGS} ${LDFLAGS} ${SDL_FLAGS} ${EXTRA_LDFLAGS} \
+ ${CC} ${LDFLAGS} `${SDL_CONFIG} --libs` \
-o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.o
do-install: