aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/bugle
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-12-03 14:37:40 +0800
committerrafan <rafan@FreeBSD.org>2006-12-03 14:37:40 +0800
commit302a1cec1173bf830fcd0a8b1df85d3313f872bb (patch)
treee970d5e88c2ff62fef10fb51458aef1be4771e03 /graphics/bugle
parentafa2d1555da449804a4710f173352957b0c4aaee (diff)
downloadfreebsd-ports-gnome-302a1cec1173bf830fcd0a8b1df85d3313f872bb.tar.gz
freebsd-ports-gnome-302a1cec1173bf830fcd0a8b1df85d3313f872bb.tar.zst
freebsd-ports-gnome-302a1cec1173bf830fcd0a8b1df85d3313f872bb.zip
- Respect X11BASE
Approved by: maintainer (implicit)
Diffstat (limited to 'graphics/bugle')
-rw-r--r--graphics/bugle/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/graphics/bugle/Makefile b/graphics/bugle/Makefile
index 9d8ff0c66a5e..a04d16e5a881 100644
--- a/graphics/bugle/Makefile
+++ b/graphics/bugle/Makefile
@@ -28,7 +28,8 @@ USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/${PORTNAME}
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS=--enable-ltdl-install=no
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
- LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
+ LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib" \
+ GL_LIBS="-L${X11BASE}/lib"
MAN1= gldb.1
MAN3= bugle.3
@@ -69,4 +70,7 @@ CONFIGURE_ARGS+=--with-threads=pthreads
CONFIGURE_ARGS+=--with-threads=single
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},g' ${WRKSRC}/gentokens/find_header.perl
+
.include <bsd.port.post.mk>