aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/c-a-i-r
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-21 00:23:28 +0800
committermat <mat@FreeBSD.org>2016-06-21 00:23:28 +0800
commitbc12b6beb26907f267f34c1f8598d120cabecbae (patch)
treee83ee6693050a76e305a95a376451aa583df151e /graphics/c-a-i-r
parent5616a93eb39854a280bacec86824bbec7824d5b3 (diff)
downloadfreebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.tar.gz
freebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.tar.zst
freebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.zip
With the power of USES=dos2unix, get rid of most patches and files
with CRLF. While there, run make makepatch, rename patches to use the new scheme, and various fixes. With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'graphics/c-a-i-r')
-rw-r--r--graphics/c-a-i-r/Makefile3
-rw-r--r--graphics/c-a-i-r/files/patch-CAIR.cpp76
2 files changed, 40 insertions, 39 deletions
diff --git a/graphics/c-a-i-r/Makefile b/graphics/c-a-i-r/Makefile
index 7817ee3d6062..a4db05a84714 100644
--- a/graphics/c-a-i-r/Makefile
+++ b/graphics/c-a-i-r/Makefile
@@ -10,7 +10,8 @@ DISTNAME= CAIR_v${PORTVERSION}
MAINTAINER= buganini@gmail.com
COMMENT= Content Aware Image Resizer is an implementation of seam carving
-USES= gmake zip
+USES= dos2unix gmake zip
+DOS2UNIX_GLOB= *.cpp
MAKE_ARGS+= CC="${CXX}"
diff --git a/graphics/c-a-i-r/files/patch-CAIR.cpp b/graphics/c-a-i-r/files/patch-CAIR.cpp
index 9292b9dbe1bc..ea099db1c685 100644
--- a/graphics/c-a-i-r/files/patch-CAIR.cpp
+++ b/graphics/c-a-i-r/files/patch-CAIR.cpp
@@ -1,38 +1,38 @@
---- CAIR.cpp.orig 2010-03-16 08:51:06.000000000 +0800
-+++ CAIR.cpp 2010-03-16 08:55:11.000000000 +0800
-@@ -276,7 +276,7 @@
- //Our thread function for the Grayscale
- void * Gray_Quadrant( void * id )
- {
-- int num = *((int *)id);
-+ long int num = *((long int *)id);
-
- while( true )
- {
-@@ -437,7 +437,7 @@
- //The thread function, splitting the image into strips
- void * Edge_Quadrant( void * id )
- {
-- int num = *((int *)id);
-+ long int num = *((long int *)id);
-
- while( true )
- {
-@@ -744,7 +744,7 @@
- //This works like Remove_Quadrant, strips across the image.
- void * Add_Quadrant( void * id )
- {
-- int num = *((int *)id);
-+ long int num = *((long int *)id);
- Thread_Params add_area;
-
- while( true )
-@@ -907,7 +907,7 @@
- //the areas are not quadrants, rather, more like strips, but I keep the name convention
- void * Remove_Quadrant( void * id )
- {
-- int num = *((int *)id);
-+ long int num = *((long int *)id);
- Thread_Params remove_area;
-
- while( true )
+--- CAIR.cpp.orig 2016-06-20 15:51:27 UTC
++++ CAIR.cpp
+@@ -276,7 +276,7 @@ inline CML_byte Grayscale_Pixel( CML_RGB
+ //Our thread function for the Grayscale
+ void * Gray_Quadrant( void * id )
+ {
+- int num = *((int *)id);
++ long int num = *((long int *)id);
+
+ while( true )
+ {
+@@ -437,7 +437,7 @@ int Convolve_Pixel( CML_image_ptr * Sour
+ //The thread function, splitting the image into strips
+ void * Edge_Quadrant( void * id )
+ {
+- int num = *((int *)id);
++ long int num = *((long int *)id);
+
+ while( true )
+ {
+@@ -744,7 +744,7 @@ CML_RGBA Average_Pixels( CML_RGBA Pixel1
+ //This works like Remove_Quadrant, strips across the image.
+ void * Add_Quadrant( void * id )
+ {
+- int num = *((int *)id);
++ long int num = *((long int *)id);
+ Thread_Params add_area;
+
+ while( true )
+@@ -907,7 +907,7 @@ bool CAIR_Add( CML_image * Source, CML_i
+ //the areas are not quadrants, rather, more like strips, but I keep the name convention
+ void * Remove_Quadrant( void * id )
+ {
+- int num = *((int *)id);
++ long int num = *((long int *)id);
+ Thread_Params remove_area;
+
+ while( true )