aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/cairo
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2008-10-20 00:02:22 +0800
committermezz <mezz@FreeBSD.org>2008-10-20 00:02:22 +0800
commit5eaba666dda7bbd0a30f8c89aa0ff1d7a9ee488a (patch)
treea1c563e25b06037a5d8d71438415c092d1a56315 /graphics/cairo
parentd3b569566cf678e9020a12465a5f1b7c3914df9b (diff)
downloadfreebsd-ports-gnome-5eaba666dda7bbd0a30f8c89aa0ff1d7a9ee488a.tar.gz
freebsd-ports-gnome-5eaba666dda7bbd0a30f8c89aa0ff1d7a9ee488a.tar.zst
freebsd-ports-gnome-5eaba666dda7bbd0a30f8c89aa0ff1d7a9ee488a.zip
Add XCB support with optional. Enable it by default, since future version of
x11-wm/awesome needs it. Bump the PORTREVISION. PR: ports/126993 Submitted by: bf <bf2006a@yahoo.com> Requested by: Nikos Ntarmos <ntarmos@ceid.upatras.gr>
Diffstat (limited to 'graphics/cairo')
-rw-r--r--graphics/cairo/Makefile15
-rw-r--r--graphics/cairo/pkg-plist3
2 files changed, 16 insertions, 2 deletions
diff --git a/graphics/cairo/Makefile b/graphics/cairo/Makefile
index 7a9eeb3730ad..ce601fe7a4b9 100644
--- a/graphics/cairo/Makefile
+++ b/graphics/cairo/Makefile
@@ -8,7 +8,7 @@
PORTNAME= cairo
PORTVERSION= 1.6.4
-PORTREVISION?= 2
+PORTREVISION?= 3
PORTEPOCH?= 1
CATEGORIES= graphics
MASTER_SITES= http://cairographics.org/releases/
@@ -42,7 +42,8 @@ USE_XORG+= xrender
PLIST_SUB+= X11=""
.endif
-OPTIONS+= GLITZ "Enable Glitz OpenGL Support" Off
+OPTIONS+= GLITZ "Enable Glitz OpenGL Support" Off \
+ XCB "Enable XCB (X C-language Binding) Support" On
.include <bsd.port.pre.mk>
@@ -55,6 +56,16 @@ CONFIGURE_ARGS+= --disable-glitz
PLIST_SUB+= GLITZ="@comment "
.endif
+.ifdef(WITH_XCB)
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/xcb-renderutil.pc:${PORTSDIR}/x11/xcb-util
+RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/xcb-renderutil.pc:${PORTSDIR}/x11/xcb-util
+CONFIGURE_ARGS+= --enable-xcb
+PLIST_SUB+= XCB=""
+.else
+CONFIGURE_ARGS+= --disable-xcb
+PLIST_SUB+= XCB="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
${WRKSRC}/test/Makefile.in
diff --git a/graphics/cairo/pkg-plist b/graphics/cairo/pkg-plist
index c81b6e936df0..d1b67967143d 100644
--- a/graphics/cairo/pkg-plist
+++ b/graphics/cairo/pkg-plist
@@ -5,6 +5,8 @@ include/cairo/cairo-ft.h
include/cairo/cairo-pdf.h
include/cairo/cairo-ps.h
include/cairo/cairo-svg.h
+%%XCB%%include/cairo/cairo-xcb-xrender.h
+%%XCB%%include/cairo/cairo-xcb.h
%%X11%%include/cairo/cairo-xlib-xrender.h
%%X11%%include/cairo/cairo-xlib.h
include/cairo/cairo.h
@@ -19,6 +21,7 @@ libdata/pkgconfig/cairo-pdf.pc
libdata/pkgconfig/cairo-png.pc
libdata/pkgconfig/cairo-ps.pc
libdata/pkgconfig/cairo-svg.pc
+%%XCB%%libdata/pkgconfig/cairo-xcb.pc
%%X11%%libdata/pkgconfig/cairo-xlib.pc
%%X11%%libdata/pkgconfig/cairo-xlib-xrender.pc
@dirrm include/cairo