aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/cairo
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-01-10 13:22:13 +0800
committermarcus <marcus@FreeBSD.org>2009-01-10 13:22:13 +0800
commit6d8ed8f7c7511223163de715a97ffc04bf6fada9 (patch)
tree40dc015efe383243b0880df377f73ee250da7de7 /graphics/cairo
parentc7f342a8d7b82e85b9625c4403600fc20ce41da6 (diff)
downloadfreebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.tar.gz
freebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.tar.zst
freebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.zip
Presenting GNOME 2.24 for FreeBSD.
See http://library.gnome.org/misc/release-notes/2.24/ for the general release notes. On the FreeBSD front, this release introduces Fuse support in HAL, adds multi-CPU support to libgtop, WebKit updates, and fixes some long-standing seahorse and gnome-keyring bugs. The documentation updates to the website are forthcoming. This release features commits by adamw, ahze, kwm, mezz, and myself. It would not have been possible without are contributors and testers: Alexander Loginov Craig Butler [1] Dmitry Marakasov [6] Eric L. Chen Joseph S. Atkinson Kris Moore Lapo Luchini [7] Nikos Ntarmos Pawel Worach Romain Tartiere TAOKA Fumiyoshi [3] Yasuda Keisuke Zyl aZ [4] bf [2] [5] Florent Thoumie Peter Wemm pluknet PR: 125857 [1] 126993 [2] 130031 [3] 127399 [4] 127661 [5] 124302 [6] 129570 [7] 129936 123790
Diffstat (limited to 'graphics/cairo')
-rw-r--r--graphics/cairo/Makefile8
-rw-r--r--graphics/cairo/distinfo6
-rw-r--r--graphics/cairo/files/patch-src_cairo-ft-font.c28
-rw-r--r--graphics/cairo/pkg-plist1
4 files changed, 8 insertions, 35 deletions
diff --git a/graphics/cairo/Makefile b/graphics/cairo/Makefile
index 75026f4327c7..511c425010c9 100644
--- a/graphics/cairo/Makefile
+++ b/graphics/cairo/Makefile
@@ -3,12 +3,12 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/graphics/cairo/Makefile,v 1.3 2008/06/16 21:35:57 mezz Exp $
+# $MCom: ports/graphics/cairo/Makefile,v 1.89 2008/12/16 03:06:44 marcus Exp $
#
PORTNAME= cairo
-PORTVERSION= 1.6.4
-PORTREVISION?= 4
+PORTVERSION= 1.8.6
+PORTREVISION?= 0
PORTEPOCH?= 1
CATEGORIES= graphics
MASTER_SITES= http://cairographics.org/releases/
@@ -27,7 +27,7 @@ LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
CONFIGURE_ARGS= --with-html-dir=${DOCSDIR} \
--enable-pdf \
--enable-ps
-USE_GNOME= gnometarget gnomehack ltverhack referencehack
+USE_GNOME= gnomehack ltverhack referencehack
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
diff --git a/graphics/cairo/distinfo b/graphics/cairo/distinfo
index afffbc8d7480..0c7bb07eac58 100644
--- a/graphics/cairo/distinfo
+++ b/graphics/cairo/distinfo
@@ -1,3 +1,3 @@
-MD5 (cairo-1.6.4.tar.gz) = a198d509f9e3a35b78de8bb02174ebb9
-SHA256 (cairo-1.6.4.tar.gz) = 7f0ce28c358706913bc39e6930a18ae89f3b9a6aa17998faa2b59d1e0e2b4f42
-SIZE (cairo-1.6.4.tar.gz) = 5042623
+MD5 (cairo-1.8.6.tar.gz) = 4e64139ef6f668df24450f3b81dd0771
+SHA256 (cairo-1.8.6.tar.gz) = 93a347af0cecf258be8fb54265b16a0fb16317df4a32896141d2987c30773535
+SIZE (cairo-1.8.6.tar.gz) = 6616544
diff --git a/graphics/cairo/files/patch-src_cairo-ft-font.c b/graphics/cairo/files/patch-src_cairo-ft-font.c
deleted file mode 100644
index 8cd60665fef0..000000000000
--- a/graphics/cairo/files/patch-src_cairo-ft-font.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/cairo-ft-font.c.orig Tue Aug 16 14:46:46 2005
-+++ src/cairo-ft-font.c Tue Aug 16 14:46:59 2005
-@@ -44,6 +44,11 @@
- #include <fontconfig/fontconfig.h>
- #include <fontconfig/fcfreetype.h>
-
-+#include <sys/types.h>
-+#include <stdlib.h>
-+#include <time.h>
-+#include <unistd.h>
-+
- #include <ft2build.h>
- #include FT_FREETYPE_H
- #include FT_OUTLINE_H
-@@ -257,7 +262,12 @@ _cairo_ft_unscaled_font_init_key (cairo_
- key->id = id;
-
- /* 1607 is just an arbitrary prime. */
-- hash = _cairo_hash_string (filename);
-+ if (filename != NULL) {
-+ hash = _cairo_hash_string (filename);
-+ } else {
-+ srandom(time(NULL) * getpid());
-+ hash = random();
-+ }
- hash += ((unsigned long) id) * 1607;
-
- key->base.hash_entry.hash = hash;
diff --git a/graphics/cairo/pkg-plist b/graphics/cairo/pkg-plist
index d1b67967143d..ec0206e6a37d 100644
--- a/graphics/cairo/pkg-plist
+++ b/graphics/cairo/pkg-plist
@@ -5,6 +5,7 @@ include/cairo/cairo-ft.h
include/cairo/cairo-pdf.h
include/cairo/cairo-ps.h
include/cairo/cairo-svg.h
+include/cairo/cairo-version.h
%%XCB%%include/cairo/cairo-xcb-xrender.h
%%XCB%%include/cairo/cairo-xcb.h
%%X11%%include/cairo/cairo-xlib-xrender.h