aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/cal3d
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2006-02-23 18:40:44 +0800
committerade <ade@FreeBSD.org>2006-02-23 18:40:44 +0800
commitda880765886f48c0ac8fd253e5601d04ea853215 (patch)
tree55155f50e8a40ea2e2a16e2331e8cbb919b7d04f /graphics/cal3d
parentba4beb1ea11e6147a9b30969be42685d1c709e56 (diff)
downloadfreebsd-ports-gnome-da880765886f48c0ac8fd253e5601d04ea853215.tar.gz
freebsd-ports-gnome-da880765886f48c0ac8fd253e5601d04ea853215.tar.zst
freebsd-ports-gnome-da880765886f48c0ac8fd253e5601d04ea853215.zip
Conversion to a single libtool environment.
Approved by: portmgr (kris)
Diffstat (limited to 'graphics/cal3d')
-rw-r--r--graphics/cal3d/Makefile19
-rw-r--r--graphics/cal3d/pkg-plist1
2 files changed, 12 insertions, 8 deletions
diff --git a/graphics/cal3d/Makefile b/graphics/cal3d/Makefile
index 36ec4688246f..b8423e73ab00 100644
--- a/graphics/cal3d/Makefile
+++ b/graphics/cal3d/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cal3d
PORTVERSION= 0.10.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,13 +18,12 @@ COMMENT= Skeletal based 3d character animation library written in C++
CONFLICTS= cal3d-devel-[0-9]*
-USE_BZIP2= yes
-USE_REINPLACE= yes
-USE_GNOME= pkgconfig
-USE_AUTOTOOLS= automake:19 autoheader:259 libtool:15:inc
-AUTOMAKE_ARGS= "--add-missing"
-INSTALLS_SHLIB= yes
-CONFIGURE_ARGS+= --disable-static
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GNOME= pkgconfig
+USE_AUTOTOOLS= automake:19 autoheader:259 libtool:15
+AUTOMAKE_ARGS= "--add-missing"
+INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
@@ -36,4 +35,8 @@ pre-configure:
cd ${WRKSRC} && ${AUTOHEADER}
cd ${WRKSRC} && ${LIBTOOLIZE} --automake --force
+# XXX: handle slight differences between 6.x and 5.x/4.x
+post-install:
+ @${RM} -f ${PREFIX}/lib/libcal3d.a
+
.include <bsd.port.post.mk>
diff --git a/graphics/cal3d/pkg-plist b/graphics/cal3d/pkg-plist
index 079d377287ae..f313a03cc89e 100644
--- a/graphics/cal3d/pkg-plist
+++ b/graphics/cal3d/pkg-plist
@@ -41,6 +41,7 @@ include/cal3d/tinystr.h
include/cal3d/tinyxml.h
include/cal3d/vector.h
@dirrm include/cal3d
+lib/libcal3d.la
lib/libcal3d.so
lib/libcal3d.so.11
libdata/pkgconfig/cal3d.pc