aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/cbviewer
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-12-07 23:33:53 +0800
committerpawel <pawel@FreeBSD.org>2012-12-07 23:33:53 +0800
commita7de953fccbd0f761d4c9881ad1a2e7769679580 (patch)
tree6200fd1d3b5fe8d436f5f5234cb1c513716c6258 /graphics/cbviewer
parentc74b5c840b61be932498f7411ff0ec101dd7f108 (diff)
downloadfreebsd-ports-gnome-a7de953fccbd0f761d4c9881ad1a2e7769679580.tar.gz
freebsd-ports-gnome-a7de953fccbd0f761d4c9881ad1a2e7769679580.tar.zst
freebsd-ports-gnome-a7de953fccbd0f761d4c9881ad1a2e7769679580.zip
CBViewer is a comic book viewer for comic book archives in cbz, cbr, zip, and
rar formats. The interface is written in java but it requires unrar for linux or windows depending which OS you are running on. It will do zip files in java. WWW: http://www.renuncln.com/programs/cbviewer/ PR: ports/173294 Submitted by: nemysis@gmx.ch Feature safe: yes
Diffstat (limited to 'graphics/cbviewer')
-rw-r--r--graphics/cbviewer/Makefile57
-rw-r--r--graphics/cbviewer/distinfo4
-rw-r--r--graphics/cbviewer/files/cbviewer.in9
-rw-r--r--graphics/cbviewer/pkg-descr5
4 files changed, 75 insertions, 0 deletions
diff --git a/graphics/cbviewer/Makefile b/graphics/cbviewer/Makefile
new file mode 100644
index 000000000000..ee617dfc0ad3
--- /dev/null
+++ b/graphics/cbviewer/Makefile
@@ -0,0 +1,57 @@
+# Created by: nemysis@gmx.ch
+# $FreeBSD$
+
+PORTNAME= cbviewer
+PORTVERSION= 0.8
+CATEGORIES= graphics java
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/CBViewer%200.8/ \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Comic book viewer for comic book archives in cbz, cbr, zip, rar
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= unrar:${PORTSDIR}/archivers/unrar \
+ unzip:${PORTSDIR}/archivers/unzip
+
+FETCH_ARGS?= -Fpr
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+NO_BUILD= yes
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/java/cbviewer/CBViewer.jar \
+ share/pixmaps/${PORTNAME}.png
+PLIST_DIRSTRY= share/java/cbviewer
+
+PORTDOCS= CREDITS
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+
+SUB_FILES= ${PORTNAME}
+
+DESKTOP_ENTRIES="CBViewer" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Application;Graphics;Viewer;" true
+
+.include <bsd.port.options.mk>
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.jar ${DATADIR}
+
+post-install:
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps
+
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/cbviewer/distinfo b/graphics/cbviewer/distinfo
new file mode 100644
index 000000000000..bc822b5b35a9
--- /dev/null
+++ b/graphics/cbviewer/distinfo
@@ -0,0 +1,4 @@
+SHA256 (cbviewer/cbviewer-0.8.zip) = 747323783204caa75384244a45c3b1d80579f58419d1a332893d8e186ac117c6
+SIZE (cbviewer/cbviewer-0.8.zip) = 303511
+SHA256 (cbviewer/cbviewer.png) = 8aab7a0cb882196883508d369bd3b2656a59eb180b4b5ddea8444fa0e8033d1e
+SIZE (cbviewer/cbviewer.png) = 3334
diff --git a/graphics/cbviewer/files/cbviewer.in b/graphics/cbviewer/files/cbviewer.in
new file mode 100644
index 000000000000..194d4af31fc9
--- /dev/null
+++ b/graphics/cbviewer/files/cbviewer.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+export JAVA_VERSION="%%JAVA_VERSION%%"
+
+cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" \
+-Djava.ext.dirs="%%DATADIR%%" -jar "%%DATADIR%%/CBViewer.jar" "${@}"
diff --git a/graphics/cbviewer/pkg-descr b/graphics/cbviewer/pkg-descr
new file mode 100644
index 000000000000..64b8e4d6eff2
--- /dev/null
+++ b/graphics/cbviewer/pkg-descr
@@ -0,0 +1,5 @@
+CBViewer is a comic book viewer for comic book archives in cbz, cbr, zip, and
+rar formats. The interface is written in java but it requires unrar for linux
+or windows depending which OS you are running on. It will do zip files in java.
+
+WWW: http://www.renuncln.com/programs/cbviewer/