aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/chbg
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2002-08-31 19:29:29 +0800
committernetchild <netchild@FreeBSD.org>2002-08-31 19:29:29 +0800
commitb524fea5c1c1c336af140df739b477c892d22f05 (patch)
tree7fe3af40206525f6bd4e4c19ee5d73ee95e82449 /graphics/chbg
parentcb51ec48647fa24bb9975184b558a47f529f83a4 (diff)
downloadfreebsd-ports-gnome-b524fea5c1c1c336af140df739b477c892d22f05.tar.gz
freebsd-ports-gnome-b524fea5c1c1c336af140df739b477c892d22f05.tar.zst
freebsd-ports-gnome-b524fea5c1c1c336af140df739b477c892d22f05.zip
Switch to GNOMENG, use REINPLACE.
Diffstat (limited to 'graphics/chbg')
-rw-r--r--graphics/chbg/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/graphics/chbg/Makefile b/graphics/chbg/Makefile
index 996bb55918c9..1c14218372ff 100644
--- a/graphics/chbg/Makefile
+++ b/graphics/chbg/Makefile
@@ -17,31 +17,29 @@ MAINTAINER= netchild@FreeBSD.org
LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf/
-# GNOME parts aren't prefix safe, the get installed into "gnome-config --prefix"
+# GNOME parts aren't prefix safe, they install into "gnome-config --prefix"
USE_X_PREFIX= yes
+USE_GNOMENG= yes
WANT_GNOME= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS}" CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
-.if defined(HAVE_GNOME)
-USE_GNOMECTRL= yes
+.if ${HAVE_GNOME:Mlibcapplet} != ""
+USE_GNOME+= gnomeprefix gnomehack libcapplet
+PKGNAMESUFFIX= -gnome
.else
USE_GTK= yes
.endif
MAN1= chbg.1
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(GNOME_PREFIX\)/share/control-center|\$\(GNOME_PREFIX\)/share/gnome/control-center|g; \
- s|\$\(GNOME_PREFIX\)/share/pixmaps|\$\(GNOME_PREFIX\)/share/gnome/pixmaps|g; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.post.mk>