aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/cinepaint/Makefile
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-02-02 03:11:14 +0800
committerbeech <beech@FreeBSD.org>2008-02-02 03:11:14 +0800
commit08101affa258ca912a98963b6e92e535fb244182 (patch)
tree333e5232da83d34019ea7e8d6f94c3b5374638fb /graphics/cinepaint/Makefile
parent8830a3ac0d1e444b0ca424d5cd751fad8e82620c (diff)
downloadfreebsd-ports-gnome-08101affa258ca912a98963b6e92e535fb244182.tar.gz
freebsd-ports-gnome-08101affa258ca912a98963b6e92e535fb244182.tar.zst
freebsd-ports-gnome-08101affa258ca912a98963b6e92e535fb244182.zip
- Update to 0.22
New Features: o native OpenEXR Half sample type substitutes the older RnH 16-bit float o load/save multilayerd OpenEXR files like from Blender o load/save 16-bit Half Tiff's o precise drawing with tablet o hardware speedup in gamma-expose and Brightness/Contrast Adjustments o dynamic colour visualisation in ICC Examin plug-in o UTF-8 support through Gtk2 o UFRaw plug-in ready o CMS defaults to Oyranos as of 0.22-1: o Tango icons for toolbox only o Retinex plug-in Bugfixes: o missing stdio.h include for printf in fl_i18n_cinepaint.cxx o --pedantic is omitted in openexr directory for --enable-debug configure option o patch to link in GTK libs o all other see Change Log PR: ports/114490 Submitted by: David Yeske <dyeske@gmail.com>
Diffstat (limited to 'graphics/cinepaint/Makefile')
-rw-r--r--graphics/cinepaint/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/graphics/cinepaint/Makefile b/graphics/cinepaint/Makefile
index 6fc820b5f80f..2d767d950ef4 100644
--- a/graphics/cinepaint/Makefile
+++ b/graphics/cinepaint/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= cinepaint
-PORTVERSION= 0.20
-PORTREVISION= 3
+PORTVERSION= 0.22
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-1
MAINTAINER= dyeske@gmail.com
@@ -22,12 +20,11 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
USE_AUTOTOOLS= libtool:15
-USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_PYTHON= yes
-USE_GMAKE= yes
USE_GNOME= gtk12
-INSTALLS_SHLIB= yes
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
MAN1= cinepaint.1 cinepainttool.1
@@ -35,7 +32,11 @@ PLIST_SUB= VER=${PORTVERSION}-1
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-1
-.if !defined(WITHOUT_OPENEXR)
+OPTIONS= OPENEXR "Use OpenEXR" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_OPENEXR)
LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
fltk.1:${PORTSDIR}/x11-toolkits/fltk-threads
CONFIGURE_ARGS+= --with-openexr-prefix=${LOCALBASE}
@@ -47,10 +48,6 @@ PLIST_SUB+= OPENEXR:="@comment "
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042 && ${ARCH} == "amd64"
-BROKEN= does not compile
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
's| -Wall||' \