aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/cinepaint
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-13 05:42:32 +0800
committerbapt <bapt@FreeBSD.org>2012-06-13 05:42:32 +0800
commitf5eba1acd02cb57a7650fe6c33b912240f6ab8ab (patch)
tree785d921da1883d2c1df77c5add82a844e2ae090b /graphics/cinepaint
parenteb2a7f0a6ba691b8505dc2684f14abff26a76009 (diff)
downloadfreebsd-ports-gnome-f5eba1acd02cb57a7650fe6c33b912240f6ab8ab.tar.gz
freebsd-ports-gnome-f5eba1acd02cb57a7650fe6c33b912240f6ab8ab.tar.zst
freebsd-ports-gnome-f5eba1acd02cb57a7650fe6c33b912240f6ab8ab.zip
Conver to new options framework
Diffstat (limited to 'graphics/cinepaint')
-rw-r--r--graphics/cinepaint/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/cinepaint/Makefile b/graphics/cinepaint/Makefile
index 1e9e85c9651d..687ea4c5a644 100644
--- a/graphics/cinepaint/Makefile
+++ b/graphics/cinepaint/Makefile
@@ -35,14 +35,16 @@ PLIST_SUB= VER=${PORTVERSION}-1
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-1
-OPTIONS= OPENEXR "Use OpenEXR" on
+OPTIONS_DEFINE= OPENEXR
+OPTIONS_DEFAULT= OPENEXR
+OPENEXR_DESC= Use OpenEXR
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_OPENEXR)
+.if ${PORT_OPTIONS:MOPENEXR}
LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
fltk.1:${PORTSDIR}/x11-toolkits/fltk
CONFIGURE_ARGS+= --with-openexr-prefix=${LOCALBASE}
@@ -71,4 +73,4 @@ post-patch:
${REINPLACE_CMD} -e '/^#include <FL/s|.h>$$|.H>|; /^#include "FL/s|.h"$$|.H"|; \
s|fl_file_chooser.H|Fl_File_Chooser.H|g; s|#include <Fl|#include <FL|g; s|<FL/gl.H>|<FL/gl.h>|'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>