aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/cqcam
diff options
context:
space:
mode:
authoralex <alex@FreeBSD.org>2000-07-14 20:46:30 +0800
committeralex <alex@FreeBSD.org>2000-07-14 20:46:30 +0800
commit25e2158019e31702b4fcc29f629bce7e9416d19d (patch)
tree4d5fe0ce6775ce4c0f4e92570df7dc9e6906305f /graphics/cqcam
parent654dc37e211c251faa0293424341590f1e625c49 (diff)
downloadfreebsd-ports-gnome-25e2158019e31702b4fcc29f629bce7e9416d19d.tar.gz
freebsd-ports-gnome-25e2158019e31702b4fcc29f629bce7e9416d19d.tar.zst
freebsd-ports-gnome-25e2158019e31702b4fcc29f629bce7e9416d19d.zip
Update to version 0.90p9.
With this version, it is no longer only a frame grabber, but a whole control program. Thus, adjust COMMENT/DESCR. As a bonus, it should fix bento build. PR: 19824 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to 'graphics/cqcam')
-rw-r--r--graphics/cqcam/Makefile38
-rw-r--r--graphics/cqcam/distinfo2
-rw-r--r--graphics/cqcam/files/patch-ab50
-rw-r--r--graphics/cqcam/files/patch-ac22
-rw-r--r--graphics/cqcam/files/patch-ad10
-rw-r--r--graphics/cqcam/files/patch-ae10
-rw-r--r--graphics/cqcam/pkg-comment2
-rw-r--r--graphics/cqcam/pkg-descr19
-rw-r--r--graphics/cqcam/pkg-message4
-rw-r--r--graphics/cqcam/pkg-plist13
10 files changed, 162 insertions, 8 deletions
diff --git a/graphics/cqcam/Makefile b/graphics/cqcam/Makefile
index 3322db0beacf..a0d8322fdaac 100644
--- a/graphics/cqcam/Makefile
+++ b/graphics/cqcam/Makefile
@@ -6,20 +6,50 @@
#
PORTNAME= cqcam
-PORTVERSION= 0.45a
-CATEGORIES= graphics tk82
-MASTER_SITES= ftp://ftp.freesoftware.com/pub/unixfreeware/graphics/
+PORTVERSION= 0.90p9
+CATEGORIES= graphics
+MASTER_SITES= http://www.cs.duke.edu/~reynolds/cqcam/
+DISTNAME= ${PORTNAME}-0.90pre9
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82 \
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
jpeg.9:${PORTSDIR}/graphics/jpeg
ONLY_FOR_ARCHS= i386
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -pedantic" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-asm
+INSTALL_TARGET= bininstall
+
MAN1= cqcam.1
MLINKS= cqcam.1 webcam.1 \
cqcam.1 xcqcam.1
+CQCAM_DOCS= README docs/APINOTES docs/CHANGES docs/README.webcam \
+ docs/refresh.html docs/webcam.html
+
+post-install:
+.for file in cqcam gtkcam webcam xcqcam
+ @strip ${PREFIX}/bin/${file}
+.endfor
+ ${INSTALL_MAN} ${WRKSRC}/docs/cqcam.1 ${PREFIX}/man/man1
+ @${MKDIR} ${PREFIX}/share/examples/cqcam
+ ${INSTALL_DATA} ${WRKSRC}/.cqcrc ${PREFIX}/share/examples/cqcam/sample.cqcrc
+ ${INSTALL_DATA} ${WRKSRC}/webcam/nph-webcam ${PREFIX}/share/examples/cqcam/sample.nph-webcam
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/cqcam
+.for file in ${CQCAM_DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/cqcam
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>
diff --git a/graphics/cqcam/distinfo b/graphics/cqcam/distinfo
index ff65265bbccc..e1a5151e6179 100644
--- a/graphics/cqcam/distinfo
+++ b/graphics/cqcam/distinfo
@@ -1 +1 @@
-MD5 (cqcam-0.45a.tgz) = ae0d0d7bdb68a13344089b466d8fd30a
+MD5 (cqcam-0.90pre9.tgz) = 1732df04cb536da102f54de187243fa7
diff --git a/graphics/cqcam/files/patch-ab b/graphics/cqcam/files/patch-ab
new file mode 100644
index 000000000000..5be7b04c5112
--- /dev/null
+++ b/graphics/cqcam/files/patch-ab
@@ -0,0 +1,50 @@
+--- configure.orig Mon Feb 1 16:01:12 1999
++++ configure Mon Mar 13 03:54:42 2000
+@@ -1108,8 +1108,8 @@
+ echo "configure:1109: checking if the compiler understands -pipe" >&5
+ OLDCC="$CC"
+ OLDCXX="$CXX"
+- CC="$CC -pipe"
+- CXX="$CXX -pipe"
++ CC="$CC"
++ CXX="$CXX"
+ cat > conftest.$ac_ext <<EOF
+ #line 1115 "configure"
+ #include "confdefs.h"
+@@ -1655,7 +1655,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lgtk `$gtkbin""gtk-config --libs` $LIBS"
++LIBS="`$gtkbin""$GTK_CONFIG --libs` $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 1661 "configure"
+ #include "confdefs.h"
+@@ -1694,7 +1694,7 @@
+
+ echo $ac_n "checking GTK+ version""... $ac_c" 1>&6
+ echo "configure:1697: checking GTK+ version" >&5
+- GTKV=`$gtkbin""gtk-config --version`
++ GTKV=`$gtkbin""$GTK_CONFIG --version`
+ echo "$ac_t""$GTKV" 1>&6
+ case "$GTKV" in
+ 1.0.*)
+@@ -1890,8 +1890,8 @@
+ OS_LIBCQCAM_OBJS=''
+ ;;
+ freebsd*)
+- OS_CFLAGS='-O2 -I/usr/local/include -DFREEBSD'
+- OS_LDFLAGS='-L/usr/local/lib'
++ OS_CFLAGS="$CXXFLAGS $CPPFLAGS -DFREEBSD"
++ OS_LDFLAGS="$LDFLAGS"
+ OS_LIBCQCAM_OBJS=''
+ ;;
+ bsdi*)
+@@ -2124,6 +2124,7 @@
+ s%@x_includes@%$x_includes%g
+ s%@bingroup@%$bingroup%g
+ s%@gtkbin@%$gtkbin%g
++s%@GTK_CONFIG@%$GTK_CONFIG%g
+ s%@GTK_CFLAGS@%$GTK_CFLAGS%g
+ s%@xviewlib@%$xviewlib%g
+
diff --git a/graphics/cqcam/files/patch-ac b/graphics/cqcam/files/patch-ac
new file mode 100644
index 000000000000..a4b9b4323c22
--- /dev/null
+++ b/graphics/cqcam/files/patch-ac
@@ -0,0 +1,22 @@
+--- gtkfe/Makefile.in.orig Mon Feb 1 14:25:32 1999
++++ gtkfe/Makefile.in Mon Mar 13 03:39:35 2000
+@@ -3,8 +3,8 @@
+ bindir = @bindir@
+ CC = @CC@
+ CXX = @CXX@
+-CFLAGS = -Wall @DEBUGFLAGS@ @OS_CFLAGS@ @GTK_CFLAGS@ @JPEG_CFLAGS@ `@gtkbin@gtk-config --cflags`
+-CXXFLAGS = -Wall @DEBUGFLAGS@ @OS_CFLAGS@ @GTK_CFLAGS@ @JPEG_CFLAGS@ @LOCKING@ -I../libcqcam `@gtkbin@gtk-config --cflags`
++CFLAGS = -Wall @DEBUGFLAGS@ @OS_CFLAGS@ @GTK_CFLAGS@ @JPEG_CFLAGS@ `@gtkbin@@GTK_CONFIG@ --cflags`
++CXXFLAGS = -Wall @DEBUGFLAGS@ @OS_CFLAGS@ @GTK_CFLAGS@ @JPEG_CFLAGS@ @LOCKING@ -I../libcqcam `@gtkbin@@GTK_CONFIG@ --cflags`
+ LDFLAGS = @OS_LDFLAGS@ -L../libcqcam
+ LIBS = -lcqcam @JPEG_LIBS@ @OS_LIBS@
+ INSTALL = @INSTALL@
+@@ -19,7 +19,7 @@
+ rm -f *.o core $(PROGRAMS)
+
+ gtkcam: $(OBJS) $(LIBCQCAM)
+- $(CXX) -o $@ $(OBJS) `@gtkbin@gtk-config --libs` $(LDFLAGS) $(LIBS)
++ $(CXX) -o $@ $(OBJS) `@gtkbin@@GTK_CONFIG@ --libs` $(LDFLAGS) $(LIBS)
+
+ bininstall:
+ $(INSTALL) -o root -g @bingroup@ -m 4711 $(PROGRAMS) $(bindir)
diff --git a/graphics/cqcam/files/patch-ad b/graphics/cqcam/files/patch-ad
new file mode 100644
index 000000000000..067456db16e6
--- /dev/null
+++ b/graphics/cqcam/files/patch-ad
@@ -0,0 +1,10 @@
+--- libcqcam/camera.C.orig Tue Apr 20 06:33:10 1999
++++ libcqcam/camera.C Sat Jul 8 11:51:06 2000
+@@ -18,7 +18,6 @@
+ */
+
+ #include <stdio.h>
+-#include <string.h>
+ #include <unistd.h>
+
+ #include "config.h"
diff --git a/graphics/cqcam/files/patch-ae b/graphics/cqcam/files/patch-ae
new file mode 100644
index 000000000000..2fe5f9a7f7c8
--- /dev/null
+++ b/graphics/cqcam/files/patch-ae
@@ -0,0 +1,10 @@
+--- xfe/xscan.C.orig Wed Apr 26 16:16:35 2000
++++ xfe/xscan.C Sat Jul 8 11:50:32 2000
+@@ -29,7 +29,6 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
+-#include <string.h>
+ #include <signal.h>
+ #include <sys/time.h>
+ #include <sys/stat.h>
diff --git a/graphics/cqcam/pkg-comment b/graphics/cqcam/pkg-comment
index e7c87b54bcb6..06d1669a1e1a 100644
--- a/graphics/cqcam/pkg-comment
+++ b/graphics/cqcam/pkg-comment
@@ -1 +1 @@
-Color QUICK CAM frame grabber
+Color Quickcam control program
diff --git a/graphics/cqcam/pkg-descr b/graphics/cqcam/pkg-descr
index e7c87b54bcb6..f40678008ca1 100644
--- a/graphics/cqcam/pkg-descr
+++ b/graphics/cqcam/pkg-descr
@@ -1 +1,18 @@
-Color QUICK CAM frame grabber
+cqcam - Color Quickcam (PC/Parallel) control program
+
+Features:
+ * Automatic brightness and color adjustments
+ * Batchable output for webcams
+ * Support for "millions" (24bpp) and "billions" (32bpp) modes
+ * Nearly lossless on-the-fly despeckling (removal of the "Christmas
+ lights" effect)
+ * X11 front-end with optional GTK+, XView, or Tk support and Floyd
+ dithering for 8bpp displays
+ * Support for images up to 640x480
+ * 24-bit PPM or JPEG output
+ * Streaming output for use as a continuous-feed webcam
+
+cqcam supports the Color Quickcam and Color Quickcam 2. It does not support
+B&W Quickcams, the Quickclip, the VC, or the new Quickcam Home.
+
+WWW: http://www.cs.duke.edu/~reynolds/cqcam/
diff --git a/graphics/cqcam/pkg-message b/graphics/cqcam/pkg-message
new file mode 100644
index 000000000000..3c23bfa82143
--- /dev/null
+++ b/graphics/cqcam/pkg-message
@@ -0,0 +1,4 @@
+************************************************************
+Please copy /usr/local/share/examples/cqcam/sample.cqcrc to
+~/.cqcrc, and edit it for your system.
+************************************************************
diff --git a/graphics/cqcam/pkg-plist b/graphics/cqcam/pkg-plist
index 951f0510fdbd..10b331024292 100644
--- a/graphics/cqcam/pkg-plist
+++ b/graphics/cqcam/pkg-plist
@@ -1,3 +1,14 @@
bin/cqcam
-bin/xcqcam
+bin/gtkcam
bin/webcam
+bin/xcqcam
+share/examples/cqcam/sample.cqcrc
+share/examples/cqcam/sample.nph-webcam
+share/doc/cqcam/APINOTES
+share/doc/cqcam/CHANGES
+share/doc/cqcam/README
+share/doc/cqcam/README.webcam
+share/doc/cqcam/refresh.html
+share/doc/cqcam/webcam.html
+@dirrm share/examples/cqcam
+@dirrm share/doc/cqcam