aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/cthumb/files
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-02-29 05:36:42 +0800
committerpav <pav@FreeBSD.org>2004-02-29 05:36:42 +0800
commit9bb5018bfd785b325442b01dc4f60b58ee61220d (patch)
treed18b41d06c2afe81274797772a9ad08054b08bf4 /graphics/cthumb/files
parent0c3a093a29e17b017c6257bcbf0b5e7a96154686 (diff)
downloadfreebsd-ports-gnome-9bb5018bfd785b325442b01dc4f60b58ee61220d.tar.gz
freebsd-ports-gnome-9bb5018bfd785b325442b01dc4f60b58ee61220d.tar.zst
freebsd-ports-gnome-9bb5018bfd785b325442b01dc4f60b58ee61220d.zip
- Update to 4.2
PR: ports/62693 Submitted by: Alex Kapranoff <kappa@web.1tv.ru> Approved by: maintainer
Diffstat (limited to 'graphics/cthumb/files')
-rw-r--r--graphics/cthumb/files/patch-Makefile.in29
-rw-r--r--graphics/cthumb/files/patch-configure.in11
-rw-r--r--graphics/cthumb/files/patch-cthumb.in20
3 files changed, 50 insertions, 10 deletions
diff --git a/graphics/cthumb/files/patch-Makefile.in b/graphics/cthumb/files/patch-Makefile.in
new file mode 100644
index 000000000000..eec16cbdcd8c
--- /dev/null
+++ b/graphics/cthumb/files/patch-Makefile.in
@@ -0,0 +1,29 @@
+--- Makefile.in.orig Sat Feb 14 17:17:57 2004
++++ Makefile.in Sat Feb 14 17:19:04 2004
+@@ -13,25 +13,13 @@
+ mandir=@mandir@
+ themedir=@themedir@
+
+-all: cthumb cthumb.spec
+-
+-cthumb.spec: cthumb.spec.in Makefile VERSION
+- ./configure --prefix=$(prefix)
+-
+-cthumb.1: cthumb.1.in configure
+- ./configure --prefix=$(prefix)
++all: cthumb
+
+ install: cthumb
+ install -d $(bindir) $(prefix)/share $(themedir) $(mandir)/man1
+ install -m555 cthumb $(bindir)
+ install cthumb.1 $(mandir)/man1
+ $(CPR) themes/* $(themedir)
+-
+-Makefile: Makefile.in VERSION configure
+- ./configure --prefix=/usr
+-
+-cthumb: cthumb.in VERSION configure
+- ./configure --prefix=/usr
+
+ dist: cthumb.spec cthumb
+ # make prefix=$(shell pwd)/$(DD) install
diff --git a/graphics/cthumb/files/patch-configure.in b/graphics/cthumb/files/patch-configure.in
new file mode 100644
index 000000000000..4be6fa1bddbf
--- /dev/null
+++ b/graphics/cthumb/files/patch-configure.in
@@ -0,0 +1,11 @@
+--- configure.in.orig Tue Aug 13 21:24:05 2002
++++ configure.in Tue Jan 27 18:41:42 2004
+@@ -8,7 +8,7 @@
+ dnl Checks for programs.
+ AC_PATH_PROGS(perl_path, perl5 perl, no)
+ AC_PROG_INSTALL
+-AC_CHECK_PROG(CPR, rsync, rsync -avqC, cp -r)
++AC_CHECK_PROG(CPR, cp, cp -Rf)
+ AC_SUBST(CPR)
+
+ dnl Checks for libraries.
diff --git a/graphics/cthumb/files/patch-cthumb.in b/graphics/cthumb/files/patch-cthumb.in
index 19c1ae2f67eb..60417deed452 100644
--- a/graphics/cthumb/files/patch-cthumb.in
+++ b/graphics/cthumb/files/patch-cthumb.in
@@ -1,22 +1,22 @@
---- cthumb.in.orig Sat Dec 15 18:00:19 2001
-+++ cthumb.in Sat Mar 23 23:42:12 2002
-@@ -454,6 +454,7 @@
+--- cthumb.in.orig Tue Aug 13 21:24:05 2002
++++ cthumb.in Tue Jan 27 15:56:20 2004
+@@ -476,6 +476,7 @@
if ($CheckThumbnails) {
eval "require Image::Size";
if (defined $Image::Size::VERSION) {
-+ $Image::Size::VERSION = $Image::Size::VERSION;
++ $Image::Size::VERSION = $Image::Size::VERSION;
$HaveImageSizePerlModule=1;
}
}
-@@ -557,7 +558,10 @@
+@@ -579,7 +580,10 @@
if ($NoMainIndex) {
unlink($indextmp);
} else {
-- if (system ("diff -q $indextmp $MainIndexName &> /dev/null")) {
-+ local $ENV{SHELL}='/bin/sh';
-+ system ("diff -q $indextmp $MainIndexName 2>/dev/null");
-+ my $difret = $? >> 8;
-+ if ($difret != 0) {
+- if (system ("diff $indextmp $MainIndexName >/dev/null 2>/dev/null")) {
++ local $ENV{SHELL}='/bin/sh';
++ system ("diff $indextmp $MainIndexName >/dev/null 2>/dev/null");
++ my $difret = $? >> 8;
++ if ($difret != 0) {
print "Index for $descfname in: $MainIndexName\n";
my $cmd = "mv $indextmp $MainIndexName";
if (system($cmd)) { print "cthumb warning: command '$cmd' failed: $!\n"; }