aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/dia/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-08-28 20:04:42 +0800
committersobomax <sobomax@FreeBSD.org>2001-08-28 20:04:42 +0800
commit289c36981d7e8e7c4e20fdd241e8661081a99624 (patch)
tree80591fa18bcf2c713dd8869233356aceae37ac70 /graphics/dia/Makefile
parente07c2ca63b482b3172d45131de57ceab6be8c10b (diff)
downloadfreebsd-ports-gnome-289c36981d7e8e7c4e20fdd241e8661081a99624.tar.gz
freebsd-ports-gnome-289c36981d7e8e7c4e20fdd241e8661081a99624.tar.zst
freebsd-ports-gnome-289c36981d7e8e7c4e20fdd241e8661081a99624.zip
- Rework optional GNOME dependency, so it would not confuse bento;
- enable gnomeprint support in Gnome case; - use "@*" to pass arguments from the helper script to the binary instead of $*. Submitted by: bento
Diffstat (limited to 'graphics/dia/Makefile')
-rw-r--r--graphics/dia/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/graphics/dia/Makefile b/graphics/dia/Makefile
index 940792b2a83e..a83294e92590 100644
--- a/graphics/dia/Makefile
+++ b/graphics/dia/Makefile
@@ -7,18 +7,19 @@
PORTNAME= dia
PORTVERSION= 0.88.1
+PORTREVISION= 1
CATEGORIES+= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/dia
MAINTAINER?= gnome@FreeBSD.org
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOMELIBS= yes
-WANT_GNOME= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
@@ -27,13 +28,18 @@ MAN1= dia.1
.include <bsd.port.pre.mk>
-.if defined(HAVE_GNOME)
+.if exists(${X11BASE}/bin/panel) || defined(WITH_GNOME)
USE_GNOME= yes
-CONFIGURE_ARGS= --enable-gnome
-PLIST_SUB+= DIAHELP="help/dia"
+PKGNAMESUFFIX= -gnome
+CONFIGURE_ARGS= --enable-gnome \
+ --enable-gnome-print
+PLIST_SUB+= DIAHELP="help/dia" \
+ GNOME:=""
+MAKE_ENV= HAVE_GNOME="yes"
.else
CONFIGURE_ARGS= --disable-gnome
-PLIST_SUB+= DIAHELP="dia/help"
+PLIST_SUB+= DIAHELP="dia/help" \
+ GNOME:="@comment "
.endif
pre-patch: