aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/djvulibre-nox11
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-11-22 22:44:50 +0800
committerbf <bf@FreeBSD.org>2011-11-22 22:44:50 +0800
commitd520887f64599178e73a3b74d35d903b6a5fde93 (patch)
tree36f635f54bad8acedcea0080fc0a74262fcbc30a /graphics/djvulibre-nox11
parent8b80dcd2aa4736a860c42b42d8096517ffac8fca (diff)
downloadfreebsd-ports-gnome-d520887f64599178e73a3b74d35d903b6a5fde93.tar.gz
freebsd-ports-gnome-d520887f64599178e73a3b74d35d903b6a5fde93.tar.zst
freebsd-ports-gnome-d520887f64599178e73a3b74d35d903b6a5fde93.zip
fix the build with gcc 4.6+; remove an unnecessary addition to CONFIGURE_ENV
Feature safe: yes
Diffstat (limited to 'graphics/djvulibre-nox11')
-rw-r--r--graphics/djvulibre-nox11/Makefile3
-rw-r--r--graphics/djvulibre-nox11/files/patch-libdjvu__GSmartPointer.h10
2 files changed, 11 insertions, 2 deletions
diff --git a/graphics/djvulibre-nox11/Makefile b/graphics/djvulibre-nox11/Makefile
index 7bd5102d81cb..73aa8d034af8 100644
--- a/graphics/djvulibre-nox11/Makefile
+++ b/graphics/djvulibre-nox11/Makefile
@@ -29,8 +29,7 @@ CONFIGURE_ENV= JPEG_CFLAGS="-I${LOCALBASE}/include" \
TIFF_LIBS="-L${LOCALBASE}/lib -ltiff" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
- LOCALBASE="${LOCALBASE}" \
- CXX="${CXX}"
+ LOCALBASE="${LOCALBASE}"
CONFIGURE_ARGS= --enable-threads=pthread --enable-shared
USE_LDCONFIG= yes
diff --git a/graphics/djvulibre-nox11/files/patch-libdjvu__GSmartPointer.h b/graphics/djvulibre-nox11/files/patch-libdjvu__GSmartPointer.h
new file mode 100644
index 000000000000..577600f5cd01
--- /dev/null
+++ b/graphics/djvulibre-nox11/files/patch-libdjvu__GSmartPointer.h
@@ -0,0 +1,10 @@
+--- libdjvu/GSmartPointer.h.orig 2011-03-06 12:43:17.000000000 -0500
++++ libdjvu/GSmartPointer.h 2011-11-22 09:16:50.000000000 -0500
+@@ -94,6 +94,7 @@
+ #pragma warning( disable : 4243 )
+ #endif
+
++#include <stddef.h>
+ #include "DjVuGlobal.h"
+ #include "atomic.h"
+