aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ecg2png/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-07-04 13:09:41 +0800
committerwill <will@FreeBSD.org>2000-07-04 13:09:41 +0800
commit658a156226a09d33c680227607364e37257b705a (patch)
tree615cc12c2518a5cd6bf8b5c9a65308aafdbe494a /graphics/ecg2png/Makefile
parent514ac08d3c2ae259736d8674bf9f8ef9dc20cd9f (diff)
downloadfreebsd-ports-gnome-658a156226a09d33c680227607364e37257b705a.tar.gz
freebsd-ports-gnome-658a156226a09d33c680227607364e37257b705a.tar.zst
freebsd-ports-gnome-658a156226a09d33c680227607364e37257b705a.zip
Add ecg2png, a electrocardiogram-to-PNG converter. This has got to be the
weirdest image conversion program I've ever seen. =)
Diffstat (limited to 'graphics/ecg2png/Makefile')
-rw-r--r--graphics/ecg2png/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/graphics/ecg2png/Makefile b/graphics/ecg2png/Makefile
new file mode 100644
index 000000000000..6e2ef7cc49e6
--- /dev/null
+++ b/graphics/ecg2png/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: ecg2png
+# Date created: Sun 2 Jul 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= ecg2png
+PORTVERSION= 0.30
+CATEGORIES= graphics
+MASTER_SITES= ftp://www.cardiothink.com/pub/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd
+
+USE_QT2= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${X11BASE}/include/qt2 -I${LOCALBASE}/include/gd" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+USE_GMAKE= yes
+
+.include <bsd.port.mk>