aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/enblend
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2010-04-28 05:58:27 +0800
committergahr <gahr@FreeBSD.org>2010-04-28 05:58:27 +0800
commit5a71031394b0a0b65d9d5aece3362619c2d1169f (patch)
treeabb9c1dc1cedf9be9c56cba34f1ca9ae07bd6108 /graphics/enblend
parent2b15c1b3a344354d1bb987c4199ab8c4e1cb3c88 (diff)
downloadfreebsd-ports-gnome-5a71031394b0a0b65d9d5aece3362619c2d1169f.tar.gz
freebsd-ports-gnome-5a71031394b0a0b65d9d5aece3362619c2d1169f.tar.zst
freebsd-ports-gnome-5a71031394b0a0b65d9d5aece3362619c2d1169f.zip
- Add glew to the list of supported USE_GL variables
- Patch ports depending on GLEW directly Approved by: portmgr (pav)
Diffstat (limited to 'graphics/enblend')
-rw-r--r--graphics/enblend/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index 77bfd14f7439..d7e84673c254 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -17,8 +17,7 @@ COMMENT= A tool for image blending with multiresolution splines
BUILD_DEPENDS= ${LOCALBASE}/include/boost/pool/pool.hpp:${PORTSDIR}/devel/boost-libs \
OpenEXR>=1.0:${PORTSDIR}/graphics/OpenEXR
-LIB_DEPENDS= GLEW.1:${PORTSDIR}/graphics/glew \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
lcms:${PORTSDIR}/graphics/lcms \
xmi.1:${PORTSDIR}/graphics/plotutils \
tiff.4:${PORTSDIR}/graphics/tiff
@@ -32,7 +31,7 @@ USE_AUTOTOOLS= automake:110:env autoconf:262:env
# http://groups.google.com/group/hugin-ptx/browse_thread/thread/725b1581c9889e37/50abe3387d61541a#50abe3387d61541a
# Gerald Pfeifer <gerald@pfeifer.com> asked to use 4.4+ instead of 4.3+
USE_GCC= 4.4+
-USE_GL= glut
+USE_GL= glew glut
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"