aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/enblend
diff options
context:
space:
mode:
authorgrog <grog@FreeBSD.org>2013-02-17 10:34:33 +0800
committergrog <grog@FreeBSD.org>2013-02-17 10:34:33 +0800
commit681c2c2c253986856eae88330b034a78f099dfba (patch)
tree7f795246d152fbb71309880e997bb55c95975f00 /graphics/enblend
parent4abdebf5545fd036402cce976b05996e0059daaa (diff)
downloadfreebsd-ports-gnome-681c2c2c253986856eae88330b034a78f099dfba.tar.gz
freebsd-ports-gnome-681c2c2c253986856eae88330b034a78f099dfba.tar.zst
freebsd-ports-gnome-681c2c2c253986856eae88330b034a78f099dfba.zip
Bring up to 4.1.1.
Install info files. Enable -jX build. Reviewed by: nox Approved by: nox
Diffstat (limited to 'graphics/enblend')
-rw-r--r--graphics/enblend/Makefile20
-rw-r--r--graphics/enblend/distinfo4
-rw-r--r--graphics/enblend/files/patch-boost-1.52125
-rw-r--r--graphics/enblend/files/patch-png.cxx222
4 files changed, 13 insertions, 358 deletions
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index cd1dd3357fb2..d536cf5d0a66 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= enblend
-PORTVERSION= 4.0
-PORTREVISION= 2
+PORTVERSION= 4.1.1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= enblend/enblend-enfuse/enblend-enfuse-${PORTVERSION}
+# Care: the directory is the minor release number
+MASTER_SITE_SUBDIR= enblend/enblend-enfuse/enblend-enfuse-4.1
DISTNAME= enblend-enfuse-${PORTVERSION}
MAINTAINER= grog@FreeBSD.org
@@ -18,11 +18,13 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
lcms:${PORTSDIR}/graphics/lcms \
xmi:${PORTSDIR}/graphics/plotutils \
tiff:${PORTSDIR}/graphics/tiff \
- boost_filesystem:${PORTSDIR}/devel/boost-libs
+ boost_filesystem:${PORTSDIR}/devel/boost-libs \
+ vigraimpex:${PORTSDIR}/graphics/vigra \
+ gsl:${PORTSDIR}/math/gsl
RUN_DEPENDS= OpenEXR>=1.0:${PORTSDIR}/graphics/OpenEXR
-WRKSRC= ${WRKDIR}/enblend-enfuse-4.0-753b534c819d
-
+INFO= enfuse enblend
+MAKE_JOBS_SAFE= yes
USE_AUTOTOOLS= automake:env autoconf:env
USE_GMAKE= yes
# We need a newer version of makinfo for this.
@@ -43,8 +45,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= enblend.1 enfuse.1
PLIST_FILES= bin/enblend bin/enfuse
-# run autotools
-#pre-configure:
-# cd ${WRKSRC} && ${MAKE} -f Makefile.cvs
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.info ${PREFIX}/${INFO_PATH}
.include <bsd.port.mk>
diff --git a/graphics/enblend/distinfo b/graphics/enblend/distinfo
index 74b23745bbed..88a9d73dd7d2 100644
--- a/graphics/enblend/distinfo
+++ b/graphics/enblend/distinfo
@@ -1,2 +1,2 @@
-SHA256 (enblend-enfuse-4.0.tar.gz) = a12a44c2a07894f27e1d5a1675728175a943c89b91c1ac9abacce62f08c253c4
-SIZE (enblend-enfuse-4.0.tar.gz) = 1046677
+SHA256 (enblend-enfuse-4.1.1.tar.gz) = 9d0947633ebaa0dc1211331b31009408de6fe2108751ad4190760e3a9f181bc9
+SIZE (enblend-enfuse-4.1.1.tar.gz) = 850214
diff --git a/graphics/enblend/files/patch-boost-1.52 b/graphics/enblend/files/patch-boost-1.52
deleted file mode 100644
index c9827eb53d29..000000000000
--- a/graphics/enblend/files/patch-boost-1.52
+++ /dev/null
@@ -1,125 +0,0 @@
---- src/filenameparse.cc Tue Mar 15 18:52:46 2011 +0100
-+++ src/filenameparse.cc Sat Apr 09 20:17:05 2011 -0700
-@@ -50,7 +50,7 @@
- #ifdef HAVE_BOOST_FILESYSTEM
- #include <boost/filesystem.hpp>
-
--typedef boost::filesystem::basic_path<std::string, boost::filesystem::path_traits> basic_path;
-+//typedef boost::filesystem::basic_path<std::string, boost::filesystem::path_traits> basic_path;
- #endif
-
-
-@@ -60,7 +60,7 @@
- isRelativePath(const std::string& aFilename)
- {
- #ifdef HAVE_BOOST_FILESYSTEM
-- const basic_path path(aFilename);
-+ const boost::filesystem::path path(aFilename);
- return !path.has_root_directory();
- #else
- const std::string::size_type separator = aFilename.find(PATH_SEPARATOR);
-@@ -80,7 +80,7 @@
- extractDirname(const std::string& aFilename)
- {
- #ifdef HAVE_BOOST_FILESYSTEM
-- const basic_path path(aFilename);
-+ const boost::filesystem::path path(aFilename);
- const std::string directory(path.branch_path().string());
- return directory.empty() ? DOT : directory;
- #else
-@@ -94,8 +94,8 @@
- extractBasename(const std::string& aFilename)
- {
- #ifdef HAVE_BOOST_FILESYSTEM
-- const basic_path path(aFilename);
-- return path.leaf();
-+ const boost::filesystem::path path(aFilename);
-+ return path.leaf().string();
- #else
- const std::string::size_type separator = aFilename.rfind(PATH_SEPARATOR);
- return
-@@ -110,7 +110,7 @@
- extractFilename(const std::string& aFilename)
- {
- #ifdef HAVE_BOOST_FILESYSTEM
-- const basic_path path(aFilename);
-+ const boost::filesystem::path path(aFilename);
- return basename(path);
- #else
- const std::string::size_type separator = aFilename.rfind(PATH_SEPARATOR);
-@@ -134,7 +134,7 @@
- extractExtension(const std::string& aFilename)
- {
- #ifdef HAVE_BOOST_FILESYSTEM
-- const basic_path path(aFilename);
-+ const boost::filesystem::path path(aFilename);
- return extension(path);
- #else
- const std::string::size_type dot = aFilename.rfind(DOT);
-@@ -151,11 +151,11 @@
-
- #ifdef HAVE_BOOST_FILESYSTEM
-
--inline basic_path
--removeDotsBoost(const basic_path& aPath)
-+inline boost::filesystem::path
-+removeDotsBoost(const boost::filesystem::path& aPath)
- {
-- basic_path result;
-- for (basic_path::const_iterator p = aPath.begin(); p != aPath.end(); ++p)
-+ boost::filesystem::path result;
-+ for (boost::filesystem::path::const_iterator p = aPath.begin(); p != aPath.end(); ++p)
- {
- if (*p != DOT)
- {
-@@ -166,11 +166,12 @@
- }
-
-
--inline basic_path
--removeDotDotsBoost(const basic_path& aPath)
-+inline boost::filesystem::path
-+removeDotDotsBoost(const boost::filesystem::path& aPath)
- {
- list_t directories;
-- for (basic_path::const_iterator p = aPath.begin(); p != aPath.end(); ++p)
-+ for (boost::filesystem::path::const_iterator p = aPath.begin(); p != aPath.end(); ++p)
-+
- {
- if (*p == DOTDOT &&
- !directories.empty() && directories.back() != DOTDOT)
-@@ -179,10 +180,10 @@
- }
- else
- {
-- directories.push_back(*p);
-+ directories.push_back((*p).string());
- }
- }
-- basic_path result;
-+ boost::filesystem::path result;
- for (list_t::const_iterator p = directories.begin(); p != directories.end(); ++p)
- {
- result /= *p;
-@@ -295,8 +296,8 @@
- canonicalizePath(const std::string& aPathname, bool keepDot)
- {
- #ifdef HAVE_BOOST_FILESYSTEM
-- const basic_path result =
-- removeDotDotsBoost(removeDotsBoost(basic_path(aPathname)));
-+ const boost::filesystem::path result =
-+ removeDotDotsBoost(removeDotsBoost(boost::filesystem::path(aPathname)));
- if (keepDot && result.empty())
- {
- return std::string(DOT);
-@@ -331,8 +332,8 @@
- concatPath(const std::string& aPathname, const std::string& anotherPathname)
- {
- #ifdef HAVE_BOOST_FILESYSTEM
-- basic_path path(aPathname);
-- basic_path leaf(anotherPathname);
-+ boost::filesystem::path path(aPathname);
-+ boost::filesystem::path leaf(anotherPathname);
- path /= leaf;
- return path.string();
- #else
diff --git a/graphics/enblend/files/patch-png.cxx b/graphics/enblend/files/patch-png.cxx
deleted file mode 100644
index b8ec1bd5147f..000000000000
--- a/graphics/enblend/files/patch-png.cxx
+++ /dev/null
@@ -1,222 +0,0 @@
---- ./src/vigra_impex/png.cxx.orig 2009-12-20 17:32:28.000000000 +0200
-+++ ./src/vigra_impex/png.cxx 2012-07-23 14:20:14.000000000 +0300
-@@ -81,7 +81,7 @@
- static void PngError( png_structp png_ptr, png_const_charp error_msg )
- {
- png_error_message = std::string(error_msg);
-- longjmp( png_ptr->jmpbuf, 1 );
-+ longjmp( png_jmpbuf(png_ptr), 1 );
- }
-
- // called on non-fatal errors
-@@ -213,7 +213,7 @@
- vigra_postcondition( png != 0, "could not create the read struct." );
-
- // create info struct
-- if (setjmp(png->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png))) {
- png_destroy_read_struct( &png, &info, NULL );
- vigra_postcondition( false, png_error_message.insert(0, "error in png_create_info_struct(): ").c_str() );
- }
-@@ -221,14 +221,14 @@
- vigra_postcondition( info != 0, "could not create the info struct." );
-
- // init png i/o
-- if (setjmp(png->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png))) {
- png_destroy_read_struct( &png, &info, NULL );
- vigra_postcondition( false, png_error_message.insert(0, "error in png_init_io(): ").c_str() );
- }
- png_init_io( png, file.get() );
-
- // specify that the signature was already read
-- if (setjmp(png->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png))) {
- png_destroy_read_struct( &png, &info, NULL );
- vigra_postcondition( false, png_error_message.insert(0, "error in png_set_sig_bytes(): ").c_str() );
- }
-@@ -244,13 +244,13 @@
- void PngDecoderImpl::init()
- {
- // read all chunks up to the image data
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false, png_error_message.insert(0, "error in png_read_info(): ").c_str() );
- png_read_info( png, info );
-
- // pull over the header fields
- int interlace_method, compression_method, filter_method;
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false, png_error_message.insert(0, "error in png_get_IHDR(): ").c_str() );
- png_get_IHDR( png, info, &width, &height, &bit_depth, &color_type,
- &interlace_method, &compression_method, &filter_method );
-@@ -264,7 +264,7 @@
-
- // transform palette to rgb
- if ( color_type == PNG_COLOR_TYPE_PALETTE) {
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false, png_error_message.insert(0, "error in png_palette_to_rgb(): ").c_str() );
- png_set_palette_to_rgb(png);
- color_type = PNG_COLOR_TYPE_RGB;
-@@ -273,9 +273,9 @@
-
- // expand gray values to at least one byte size
- if ( color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8 ) {
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false,png_error_message.insert(0, "error in png_set_gray_1_2_4_to_8(): ").c_str());
-- png_set_gray_1_2_4_to_8(png);
-+ png_set_expand_gray_1_2_4_to_8(png);
- bit_depth = 8;
- }
-
-@@ -283,7 +283,7 @@
- #if 0
- // strip alpha channel
- if ( color_type & PNG_COLOR_MASK_ALPHA ) {
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false, png_error_message.insert(0, "error in png_set_strip_alpha(): ").c_str() );
- png_set_strip_alpha(png);
- color_type ^= PNG_COLOR_MASK_ALPHA;
-@@ -325,12 +325,9 @@
- #if (PNG_LIBPNG_VER > 10008) && defined(PNG_READ_iCCP_SUPPORTED)
- char * dummyName;
- int dummyCompType;
-- char * profilePtr;
-- png_uint_32 profileLen;
-- if (info->valid & PNG_INFO_iCCP) {
-- png_get_iCCP(png, info, &dummyName, &dummyCompType, &profilePtr, &profileLen) ;
-- iccProfilePtr = (unsigned char *) profilePtr;
-- iccProfileLength = profileLen;
-+ if (png_get_valid(png, info, PNG_INFO_iCCP)) {
-+ png_get_iCCP(png, info, &dummyName, &dummyCompType,
-+ (unsigned char **) &iccProfilePtr, &iccProfileLength) ;
- }
- #endif
-
-@@ -340,7 +337,7 @@
- // image gamma
- double image_gamma = 0.45455;
- if ( png_get_valid( png, info, PNG_INFO_gAMA ) ) {
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false, png_error_message.insert(0, "error in png_get_gAMA(): ").c_str() );
- png_get_gAMA( png, info, &image_gamma );
- }
-@@ -349,26 +346,26 @@
- double screen_gamma = 2.2;
-
- // set gamma correction
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false, png_error_message.insert(0, "error in png_set_gamma(): ").c_str() );
- png_set_gamma( png, screen_gamma, image_gamma );
- #endif
-
- // interlace handling, get number of read passes needed
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false,png_error_message.insert(0, "error in png_set_interlace_handling(): ").c_str());
- n_interlace_passes = png_set_interlace_handling(png);
-
- // update png library state to reflect any changes that were made
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false, png_error_message.insert(0, "error in png_read_update_info(): ").c_str() );
- png_read_update_info( png, info );
-
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false,png_error_message.insert(0, "error in png_get_channels(): ").c_str());
- n_channels = png_get_channels(png, info);
-
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false,png_error_message.insert(0, "error in png_get_rowbytes(): ").c_str());
- rowsize = png_get_rowbytes(png, info);
-
-@@ -379,7 +376,7 @@
- void PngDecoderImpl::nextScanline()
- {
- for (int i=0; i < n_interlace_passes; i++) {
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false,png_error_message.insert(0, "error in png_read_row(): ").c_str());
- png_read_row(png, row_data.begin(), NULL);
- }
-@@ -545,7 +542,7 @@
- vigra_postcondition( png != 0, "could not create the write struct." );
-
- // create info struct
-- if (setjmp(png->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png))) {
- png_destroy_write_struct( &png, &info );
- vigra_postcondition( false, png_error_message.insert(0, "error in png_info_struct(): ").c_str() );
- }
-@@ -556,7 +553,7 @@
- }
-
- // init png i/o
-- if (setjmp(png->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png))) {
- png_destroy_write_struct( &png, &info );
- vigra_postcondition( false, png_error_message.insert(0, "error in png_init_io(): ").c_str() );
- }
-@@ -571,7 +568,7 @@
- void PngEncoderImpl::finalize()
- {
- // write the IHDR
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false, png_error_message.insert(0, "error in png_set_IHDR(): ").c_str() );
- png_set_IHDR( png, info, width, height, bit_depth, color_type,
- PNG_INTERLACE_NONE, PNG_COMPRESSION_TYPE_DEFAULT,
-@@ -579,7 +576,7 @@
-
- // set resolution
- if (x_resolution > 0 && y_resolution > 0) {
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false, png_error_message.insert(0, "error in png_set_pHYs(): ").c_str() );
- png_set_pHYs(png, info, (png_uint_32) (x_resolution / 0.0254 + 0.5),
- (png_uint_32) (y_resolution / 0.0254 + 0.5),
-@@ -588,7 +585,7 @@
-
- // set offset
- if (position.x > 0 && position.y > 0) {
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false, png_error_message.insert(0, "error in png_set_oFFs(): ").c_str() );
- png_set_oFFs(png, info, position.x, position.y, PNG_OFFSET_PIXEL);
- }
-@@ -597,12 +594,12 @@
- // set icc profile
- if (iccProfile.size() > 0) {
- png_set_iCCP(png, info, "icc", 0,
-- (char *)iccProfile.begin(), iccProfile.size());
-+ (png_const_bytep)iccProfile.begin(), iccProfile.size());
- }
- #endif
-
- // write the info struct
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false, png_error_message.insert(0, "error in png_write_info(): ").c_str() );
- png_write_info( png, info );
-
-@@ -634,10 +631,10 @@
- }
-
- // write the whole image
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false, png_error_message.insert(0, "error in png_write_image(): ").c_str() );
- png_write_image( png, row_pointers.begin() );
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- vigra_postcondition( false, png_error_message.insert(0, "error in png_write_end(): ").c_str() );
- png_write_end(png, info);
- }